errore hwmon0

Problemi e suggerimenti legati al software e ai pacchetti problematici.
Rispondi
Avatar utente
fabrixx
Arciere
Messaggi: 150
Iscritto il: 1 maggio 2015, 11:38
Architettura: x86_64 (64bit)
Contatta:

errore hwmon0

Messaggio da fabrixx » 7 aprile 2017, 22:55

Salve

Quando apro il terminale di Arch da un po di mesi mi compare questo errore:

Codice: Seleziona tutto

cat: /sys/class/hwmon/hwmon0/temp1_input: Argomento non valido
(standard_in) 1: syntax error

Ho cercato un po in giro ma non sono riuscito a risolvere.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: errore hwmon0

Messaggio da TheSaint » 8 aprile 2017, 8:32

Una ricerca mi dice che si tratta di problemi con la temperatura o qualche programma che vuole sapere la temperatura.
Più in là non so, perché non hai specificato niente del tuo sistema, WM o DE, lspci ecc. ecc.
Consiglierei di mostrare qualche log quali il journal, dmesg.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Avatar utente
fabrixx
Arciere
Messaggi: 150
Iscritto il: 1 maggio 2015, 11:38
Architettura: x86_64 (64bit)
Contatta:

Re: errore hwmon0

Messaggio da fabrixx » 8 aprile 2017, 21:18

lspci:
https://pastebin.com/sDAFthGs

Sistema:
http://imgur.com/a/F5SE0

Arch/Gnome 3.24

da dmesg:

Codice: Seleziona tutto

[    2.237553] wmi: Mapper loaded
[    2.238192] (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
[    2.238232] thermal LNXTHERM:00: registered as thermal_zone2
[    2.238233] ACPI: Thermal Zone [TZ00] (28 C)
[    2.238450] thermal LNXTHERM:01: registered as thermal_zone3
[    2.238451] ACPI: Thermal Zone [TZ01] (30 C)
[    2.240863] i801_smbus 0000:00:1f.3: SPD Write Disable is set
[    2.240887] i801_smbus 0000:00:1f.3: SMBus using PCI interrupt
[    2.244354] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[    2.266344] input: PC Speaker as /devices/platform/pcspkr/input/input6
[    2.270627] snd_hda_intel 0000:00:03.0: enabling device (0000 -> 0002)
[    2.270765] snd_hda_intel 0000:00:1b.0: enabling device (0000 -> 0002)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: errore hwmon0

Messaggio da TheSaint » 9 aprile 2017, 7:29

fabrixx ha scritto:

Codice: Seleziona tutto

[    2.238192] (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
Lì sta il problema, che è relativo ad un modulo del kernel. Fai una prova con un kernel-LTS se appare ancora il problema.
Forse hai qualche cosa a che fare con fan control e lm-sensors.
Salvo qualche programma installato che ha modificato/aggiunto qualche modulo del kernel obsoleto.

Codice: Seleziona tutto

lsmod |grep hw
grep hw /var/log/pacman.log
grep -Ri $HOME /sys/class/hwmon/hwmon0/temp1_input
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

VenereNera
Little John
Messaggi: 951
Iscritto il: 20 dicembre 2012, 19:50

Re: errore hwmon0

Messaggio da VenereNera » 9 aprile 2017, 13:22

Salve,
[ 2.238192] (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
Questo è dipeso da un kernel bug e qui - volendo - c'è la patch. Ce l' ho anch' io nel 4.10.8.x

Bye ^_^

Avatar utente
fabrixx
Arciere
Messaggi: 150
Iscritto il: 1 maggio 2015, 11:38
Architettura: x86_64 (64bit)
Contatta:

Re: errore hwmon0

Messaggio da fabrixx » 14 aprile 2017, 21:06

Grazie Venerenera

VenereNera
Little John
Messaggi: 951
Iscritto il: 20 dicembre 2012, 19:50

Re: errore hwmon0

Messaggio da VenereNera » 17 aprile 2017, 13:16

Di nulla ^_^

Rispondi