[Risolto] polkit-gnome non si avvia

Problemi e suggerimenti legati al software e ai pacchetti problematici.
Rispondi
Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

[Risolto] polkit-gnome non si avvia

Messaggio da pagaiocontento » 3 marzo 2017, 7:13

Dopo mesi di onorato servizio polkit-gnome non funziona più.
Ho provato a reinstallare ma non ho ottenuto risultati.
Questo è il mio /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop:

Codice: Seleziona tutto

$ cat /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop
[Desktop Entry]
Name=PolicyKit Authentication Agent
Name[it]=Agente di autenticazione per PolicyKit
Comment=PolicyKit Authentication Agent
Comment[it]=Agente di autenticazione per PolicyKit
Exec=/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
Terminal=false
Type=Application
Categories=
NoDisplay=true
#OnlyShowIn=GNOME;
Non so se c'entri ma in /etc/xdg/autostart/ ho sia polkit-gnome-authentication-agent-1.desktop
che xfce-polkit-gnome-authentication-agent-1.desktop.

Codice: Seleziona tutto

ls -l /etc/xdg/autostart/
totale 108
-rw-r--r-- 1 root root  305 26 set 20.40 at-spi-dbus-bus.desktop
-rw-r--r-- 1 root root 8295 30 set 11.08 gnome-keyring-pkcs11.desktop
-rw-r--r-- 1 root root 7838 30 set 11.08 gnome-keyring-secrets.desktop
-rw-r--r-- 1 root root 6396 30 set 11.08 gnome-keyring-ssh.desktop
-rw-r--r-- 1 root root 7741  9 ago  2016 gsettings-data-convert.desktop
-rw-r--r-- 1 root root  325 21 gen  2016 hplip-systray.desktop
-rw-r--r-- 1 root root 5785 26 gen 13.03 nm-applet.desktop
-rw-r--r-- 1 root root  331  2 mar 07.07 polkit-gnome-authentication-agent-1.desktop
-rw-r--r-- 1 root root 7954 27 gen 08.18 print-applet.desktop
-rw-r--r-- 1 root root 4821 19 gen 17.56 pulseaudio.desktop
-rw-r--r-- 1 root root 3101 29 nov 07.50 xfce4-clipman-plugin-autostart.desktop
-rw-r--r-- 1 root root 3460  7 mag  2016 xfce4-notes-autostart.desktop
-rw-r--r-- 1 root root 5267  7 set 11.22 xfce4-power-manager.desktop
-rw-r--r-- 1 root root 4587  3 mar 03.22 xfce-polkit-gnome-authentication-agent-1.desktop
-rw-r--r-- 1 root root 2288 15 set 13.47 xfsettingsd.desktop
-rw-r--r-- 1 root root 4818  3 mar 03.22 xscreensaver.desktop
Grazie per l'aiuto.
Ultima modifica di pagaiocontento il 4 marzo 2017, 23:30, modificato 1 volta in totale.
Non fingere mai di saper quel che non sai.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7927
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: polkit-gnome non si avvia

Messaggio da TheSaint » 3 marzo 2017, 8:05

Fai una prova, rinomina la ~/.config e rientra nella sessione. Tanto da vedere se ci sono conflitti di ogni sorta.
Ancor meglio se provassi con un utente nuovo.
Se invece non si risolvesse, allora sono problemi di sistema.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: polkit-gnome non si avvia

Messaggio da pagaiocontento » 4 marzo 2017, 7:02

Ho rinominato ~/.config in ~/.config1 e ho aperto una nuova sessione.
Così polkit funziona.
Ora però ho un altro problema: non riesco più a ripristinare la vecchia .config che ho spostato nel cestino e mi ritrovo con un nuovo .config e un
.config1.
Quindi, rifacendomi a quello che hai scritto, ci sono dei conflitti, cosa faccio?
Ultima modifica di pagaiocontento il 4 marzo 2017, 7:19, modificato 1 volta in totale.
Non fingere mai di saper quel che non sai.

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: polkit-gnome non si avvia

Messaggio da pagaiocontento » 4 marzo 2017, 7:13

Ho ripristinato la vecchia .config copiandola da .local/share/Trash/files
Ora sono tornato alla situazione precedente vecchia .config e polkit che non funziona.
Quindi, stando a quello che hai scritto, ci sono dei conflitti, cosa faccio?
Non fingere mai di saper quel che non sai.

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: polkit-gnome non si avvia

Messaggio da pagaiocontento » 4 marzo 2017, 15:38

Ho due interfacce grafiche: Openbox e XFCE.
Ho verificato che con la sessione XFCE polkit funziona mentre con OB no.
Potrebbe essere un indizio utile ?
Non fingere mai di saper quel che non sai.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7927
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: polkit-gnome non si avvia

Messaggio da TheSaint » 4 marzo 2017, 16:50

Quello che hai provato dimostra che il pasticcio è nella vecchia config. Qualcosa che fa conflitto con le nuove impostazioni dei programmi. Se prendi con un po di pazienza e confrontare le due config per capire quali sono i file che differiscono. Quelli sono gli imputati.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: polkit-gnome non si avvia

Messaggio da pagaiocontento » 4 marzo 2017, 23:29

Ho risolto definitivamente disinstallando XFCE4 e tenendomi solo OpenBox. In questo modo ho eliminato il doppio avvio iniziale di polkit che, credo, era la causa del problema.
Grazie.
Non fingere mai di saper quel che non sai.

Rispondi