[Risolto] gstreamer0.10

Problemi e suggerimenti legati al software e ai pacchetti problematici.
Rispondi
Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

[Risolto] gstreamer0.10

Messaggio da pagaiocontento » 1 febbraio 2017, 7:14

Non riesco ad aggiornare gstreamer0.10 e relativi plugins.
Suggerimenti?
E se disinstallassi che problemi potrei avere?
Grazie.
Ultima modifica di pagaiocontento il 5 febbraio 2017, 8:18, modificato 1 volta in totale.
Non fingere mai di saper quel che non sai.

Avatar utente
xskah
Novello Arciere
Messaggi: 102
Iscritto il: 3 febbraio 2016, 20:43
Architettura: x86_64 (64bit)

Re: gstreamer0.10

Messaggio da xskah » 1 febbraio 2017, 8:02

gstreamer0.10 si trova su AUR e da quello che ho visto dovrebbe essere stato aggiornato il 28.01. Che problemi hai durante l'aggiornamento?
Puoi disinstallarlo, però i problemi nascono quando è richiesto da altri pacchetti come dipendenza.

zorro62
Arciere
Messaggi: 320
Iscritto il: 26 aprile 2011, 18:07

Re: gstreamer0.10

Messaggio da zorro62 » 1 febbraio 2017, 9:10

installato l'altro giorno quasi tutti gstreamer10 senza problemi l'unico che puo dare problemi è il bad che richiede musicbrainz,se non ricordo male!
archlinux-xfce,archlinux.mate

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: gstreamer0.10

Messaggio da pagaiocontento » 2 febbraio 2017, 6:43

Appunto, la compilazione dei pacchetti non va a buon fine e mi dà errore.
Non fingere mai di saper quel che non sai.

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: gstreamer0.10

Messaggio da pagaiocontento » 2 febbraio 2017, 7:30

Ho trovato questo:
https://forum.antergos.com/topic/5973/g ... ompiling/3
Ma più che una soluzione mi sembra un problema.
Credo che l'unica sia aspettare.
O no?
Non fingere mai di saper quel che non sai.

zorro62
Arciere
Messaggi: 320
Iscritto il: 26 aprile 2011, 18:07

Re: gstreamer0.10

Messaggio da zorro62 » 2 febbraio 2017, 13:01

pagaiocontento ha scritto:Appunto, la compilazione dei pacchetti non va a buon fine e mi dà errore.
se non posti gli errori la vedo dura!

Codice: Seleziona tutto

me ~ $ yaourt gstreamer0.10
1 aur/gstreamer0.10 0.10.36-11 [installed] (5) (4,52)
    GStreamer Multimedia Framework
2 aur/gstreamer0.10-bad 0.10.23-24 [installed] (4) (3,68)
    GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad)
3 aur/gstreamer0.10-bad-plugins 0.10.23-24 [installed] (4) (3,68)
    GStreamer Multimedia Framework Bad Plugins (gst-plugins-bad)
4 aur/gstreamer0.10-base 0.10.36-8 [installed] (4) (3,69)
    GStreamer Multimedia Framework Base plugin libraries
5 aur/gstreamer0.10-base-plugins 0.10.36-8 [installed] (4) (3,69)
    GStreamer Multimedia Framework Base Plugins (gst-plugins-base)
6 aur/gstreamer0.10-ffmpeg 0.10.13-7 [installed] (3) (2,70)
    Gstreamer FFMpeg Plugin
7 aur/gstreamer0.10-fluendo 0.10.85-1 (66) (0,65)
    GStreamer 0.10 fluendo mpegdemux plugin
8 aur/gstreamer0.10-fluendo-mp3 0.10.32-2 (28) (0,01)
    GStreamer fluendo/Oneplay mp3 plugin
9 aur/gstreamer0.10-gnonlin 0.10.17-2 (4) (0,65)
    A library for creating non-linear video editors
10 aur/gstreamer0.10-good 0.10.31-16 [installed] (4) (3,65)
    GStreamer Multimedia Framework Good plugin libraries
11 aur/gstreamer0.10-good-plugins 0.10.31-16 [installed] (4) (3,65)
    GStreamer Multimedia Framework Good Plugins (gst-plugins-good)
12 aur/gstreamer0.10-mm 0.10.11-2 (0) (0,00)
    C++ interface for GStreamer 0.10
13 aur/gstreamer0.10-oneplay 22-2 (3) (0,00)
    This package contains every gstreamer plugin from Fluendo for gstreamer 
    0.10
14 aur/gstreamer0.10-python 0.10.22-4 [installed] (2) (1,74)
    Python bindings for GStreamer 0.10
15 aur/gstreamer0.10-ugly 0.10.19-20 [installed] (2) (1,83)
    GStreamer Multimedia Framework Ugly plugin libraries
16 aur/gstreamer0.10-ugly-plugins 0.10.19-20 [installed] (2) (1,83)
    GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)
17 aur/gstreamer0.10-vaapi 0.5.9-1 [installed] (3) (0,01)
    A collection of VA-API based plugins for GStreamer (this is the last 
archlinux-xfce,archlinux.mate

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: gstreamer0.10

Messaggio da pagaiocontento » 4 febbraio 2017, 6:48

Codice: Seleziona tutto

(1/1) Arming ConditionNeedsUpdate...
curl error: Couldn't resolve host name
==> ERRORE: impossibile aggiornare
Non fingere mai di saper quel che non sai.

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: gstreamer0.10

Messaggio da pagaiocontento » 4 febbraio 2017, 7:18

Dopo l'ennesimo, lunghissimo tentativo qualcosa sono riuscito ad installarlo.
Rimangono i problemi per:
gstreamer0.10-bad
gstreamer0.10-bad-plugins
gstreamer0.10-base
gstreamer0.10-base-plugins
gstreamer0.10-ugly
gstreamer0.10-ugly-plugins
Non fingere mai di saper quel che non sai.

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: gstreamer0.10

Messaggio da pagaiocontento » 4 febbraio 2017, 8:39

Credo di aver capito.
A questo punto sul PC su cui uso Arch 64 bit ho aggiornato tutto, su quello 32 bit non riesco ad aggiornare gstreamer0.10-base e gstreamer0.10-base-plugins perché mancano le librerie necessarie per i pacchetti dedicati a quella architetettura.
Se fosse così non credo di poter fare nulla.

Codice: Seleziona tutto

$ yaourt gstreamer0.10-base
1 aur/gstreamer0.10-base 0.10.36-8 [installed: 0.10.36-3] (4) (3,56)
    GStreamer Multimedia Framework Base plugin libraries
2 aur/gstreamer0.10-base-plugins 0.10.36-8 [installed: 0.10.36-3] (4) (3,56)
    GStreamer Multimedia Framework Base Plugins (gst-plugins-base)
3 aur/lib32-gstreamer0.10-base 0.10.36-7 (24) (1,51)
    GStreamer Multimedia Framework Base plugin libraries
4 aur/lib32-gstreamer0.10-base-plugins 0.10.36-7 (24) (1,51)
    GStreamer Multimedia Framework Base Plugins (gst-plugins-base)
==> Inserisci il numero dei pacchetti da installare (ex: 1 2 3 o 1-3)
e poi

Codice: Seleziona tutto

==> ATTENZIONE: Questo PKGBUILD indica un pacchetto suddiviso.
==> Le opzioni del pacchetto sono sconosciute
==> Dipendenze di lib32-gstreamer0.10-base
 - lib32-alsa-lib (compilazione da AUR) [makedepend]
 - lib32-cdparanoia (compilazione da AUR) [makedepend]
 - lib32-gstreamer0.10 (compilazione da AUR) [makedepend]
 - lib32-libgl (compilazione da AUR) [makedepend]
 - lib32-libtheora (compilazione da AUR) [makedepend]
 - lib32-libvisual (compilazione da AUR) [makedepend]
 - lib32-libvorbis (compilazione da AUR) [makedepend]
 - lib32-libxv (compilazione da AUR) [makedepend]
 - lib32-orc (compilazione da AUR) [makedepend]
 - lib32-pango (compilazione da AUR) [makedepend]
e finisce così

Codice: Seleziona tutto

errore: il seguente pacchetto non è stato trovato: lib32-pango
errore: il seguente pacchetto non è stato trovato: lib32-libgl
errore: il seguente pacchetto non è stato trovato: lib32-libvisual
errore: il seguente pacchetto non è stato trovato: lib32-libxv
errore: il seguente pacchetto non è stato trovato: lib32-cdparanoia
errore: il seguente pacchetto non è stato trovato: lib32-orc
errore: il seguente pacchetto non è stato trovato: lib32-libtheora
errore: il seguente pacchetto non è stato trovato: lib32-libvorbis
==> Riavviare la compilazione di lib32-gstreamer0.10-base [s/N]
Quindi la storia finisce così?
Non fingere mai di saper quel che non sai.

VenereNera
Little John
Messaggi: 951
Iscritto il: 20 dicembre 2012, 19:50

Re: gstreamer0.10

Messaggio da VenereNera » 4 febbraio 2017, 10:59


zorro62
Arciere
Messaggi: 320
Iscritto il: 26 aprile 2011, 18:07

Re: gstreamer0.10

Messaggio da zorro62 » 4 febbraio 2017, 13:01

non sono sicuro,ma credo tu debba abilitare i multilib per alcuni pacchetti,ma non ne sono certo controlla.
archlinux-xfce,archlinux.mate

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: gstreamer0.10

Messaggio da pagaiocontento » 4 febbraio 2017, 15:59

Ma il problema è proprio che il pacchetto è per architettura a 64bit.
non sono sicuro,ma credo tu debba abilitare i multilib per alcuni pacchetti,ma non ne sono certo controlla.
Ma avevo letto che multilib per i686 non serve.
Non fingere mai di saper quel che non sai.

VenereNera
Little John
Messaggi: 951
Iscritto il: 20 dicembre 2012, 19:50

Re: gstreamer0.10

Messaggio da VenereNera » 4 febbraio 2017, 16:20

L' errore comune è credere che il multilib serva alla sola x64, in realtà lavora in doppio senso. A parte il fatto che gstreamer dovrebbe essere sufficiente e fornire i giusti plugins da repo ufficiali. Sicuro serva gstreamer0.10, hai controllato quali sono i programmi che lo richiedono, non è che gst-plugins-* siano sufficienti?
AUR è una bella cosa, ma a volte costringe a installare cose in più.

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: gstreamer0.10

Messaggio da pagaiocontento » 4 febbraio 2017, 18:08

Magari!
Come faccio a sapere quali programmi richiedono gstreamer0.10?
Spero proprio nessuno.
Non fingere mai di saper quel che non sai.

Avatar utente
pagaiocontento
Arciere Provetto
Messaggi: 377
Iscritto il: 3 ottobre 2013, 18:03
Architettura: x86_64 (64bit)

Re: gstreamer0.10

Messaggio da pagaiocontento » 5 febbraio 2017, 8:17

Ho verificato con:

Codice: Seleziona tutto

yaourt -Qi
in effetti credo di poter fare a meno di gstreamer0.10-base, gstreamer0.10-ugly, gstreamer0.10-ugly-plugins e comunque, credo, di poter sostituire tutto con i vari pacchetti gst.
Un'altra soluzione è escludere questi pacchetti dall'aggiornamento in attesa di tempi migliori.
Però, dal basso della mia ignoranza e alla luce dell'esperienza fatta, credo di poter dire che multilib funziona per pacchetti 32bit da installare su pc 64bit, ma se il problema è installare pacchetti 32bit su pc con architetettura 32bit, multilib è inutilizzabile e i casi sono due: o li trovi sui repository ufficiali o lasci stare.
In ogni caso considero il problema risolto.
Grazie a tutti.
Non fingere mai di saper quel che non sai.

TnTo
Newbie
Messaggi: 1
Iscritto il: 2 febbraio 2017, 21:38
Architettura: x86_64 (64bit)

Re: [Risolto] gstreamer0.10

Messaggio da TnTo » 5 febbraio 2017, 21:24

Ho avuto lo stesso problema qualche settimana fa è ho risolto clonando manualmente il repo di git ( https://anongit.freedesktop.org/git/gst ... ommon.git/ ) nella directory in cui pacaur/yaourt non riuscivano.

Rispondi