[Risolto] il pacchetto non è valido oppure è corrotto (firma PGP)

Problemi e suggerimenti legati al software e ai pacchetti problematici.
Rispondi
Avatar utente
fabrixx
Arciere
Messaggi: 150
Iscritto il: 1 maggio 2015, 11:38
Architettura: x86_64 (64bit)
Contatta:

[Risolto] il pacchetto non è valido oppure è corrotto (firma PGP)

Messaggio da fabrixx » 25 gennaio 2017, 22:37

Salve, non aggiornavo Arch da molto e dopo aver scaricato svariati aggiornamenti al momento di applicarli mi escono decine e decine di questi messaggi:

Codice: Seleziona tutto

 lib32-gdk-pixbuf2-2...   166,7 KiB   505K/s 00:00 [######################] 100%
(269/269) verifica delle chiavi presenti nel p...  [######################] 100%
(269/269) verifica dell'integrità dei pacchetti    [######################] 100%
errore: jasper: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Il file /var/cache/pacman/pkg/jasper-2.0.10-1-x86_64.pkg.tar.xz è corrotto (il pacchetto non è valido oppure è corrotto (firma PGP)).
Vuoi eliminarlo? [S/n] 
Ho abilitato i repository gnome development ma a quanto pare ci sono pure dei problemi con questi:

Codice: Seleziona tutto

 community è aggiornato
 multilib è aggiornato
:: Aggiornamento del sistema in corso...
:: Vuoi sostituire cdrkit con community/cdrtools? [S/n] n
attenzione: gnome-clocks: la versione installata (3.22.1-1) è più recente di quella presente in extra (3.22.0+2+g74a75f7-1)
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: freetype2 sarà installato prima della sua dipendenza harfbuzz
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: python2-incremental sarà installato prima della sua dipendenza python2-twisted
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: lib32-harfbuzz sarà installato prima della sua dipendenza lib32-freetype2

Codice: Seleziona tutto

 gnome-unstable è aggiornato
errore: impossibile scaricare il pacchetto 'gnome-devel.db' da softwareperonista.com.ar : Failed to connect to softwareperonista.com.ar port 80: Nessun instradamento per l'host
errore: impossibile aggiornare gnome-devel (si è verificato un errore della libreria di download)


Alla domanda :: Vuoi sostituire cdrkit con community/cdrtools? [S/n] anche se rispondo S è lo stesso.

Ho trovato una discussione simile su questo forum ma molto datata e l'utente risolve reinstallando tutto.
Ultima modifica di fabrixx il 26 gennaio 2017, 20:50, modificato 1 volta in totale.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: il pacchetto non è valido oppure è corrotto (firma PGP)

Messaggio da TheSaint » 26 gennaio 2017, 13:04

Devi aggiornare il portachiavi di PGP. Vedi anche i links in alto a destra.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Avatar utente
fabrixx
Arciere
Messaggi: 150
Iscritto il: 1 maggio 2015, 11:38
Architettura: x86_64 (64bit)
Contatta:

Re: il pacchetto non è valido oppure è corrotto (firma PGP)

Messaggio da fabrixx » 26 gennaio 2017, 20:49

Grazie TheSaint , ho dato i comandi:

Codice: Seleziona tutto

# pacman-key --init
# pacman-key --populate archlinux
E gli aggiornamenti sono andati a buon fine.

Rispondi