[Risolto] problemi con yaourt (cairo?)

Problemi e suggerimenti legati al software e ai pacchetti problematici.
Rispondi
Avatar utente
gargamella
Arciere Provetto
Messaggi: 376
Iscritto il: 30 agosto 2009, 14:53

[Risolto] problemi con yaourt (cairo?)

Messaggio da gargamella » 22 aprile 2014, 13:30

Salve a tutti, da qualche giorno non riesco più a compilare con yaourt, qualsiasi pacchetto io tenti di compilarec da AUR, ricevo sempre questo errore legato a cairo

Codice: Seleziona tutto

configure: error: Package requirements (glib-2.0 >= 2.30.0
                  gtk+-3.0 >= 3.4.0
                  clutter-1.0 >= 1.10
                  clutter-gtk-1.0 >= 1.2
                  libecal-1.2 >= 3.5.3
                  libedataserver-1.2 >= 3.5.3
                  libical >= 0.43) were not met:

Package 'egl', required by 'cairo', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Qualcuno sa aiutarmi?

Uso arch 64 bit con gnome-shell 3.12.
Grazie...
Ultima modifica di gargamella il 24 aprile 2014, 0:44, modificato 1 volta in totale.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7959
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: problemi con yaourt (cairo?)

Messaggio da TheSaint » 22 aprile 2014, 15:37

Mostra il PKGBUILD
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Avatar utente
gargamella
Arciere Provetto
Messaggi: 376
Iscritto il: 30 agosto 2009, 14:53

Re: problemi con yaourt (cairo?)

Messaggio da gargamella » 22 aprile 2014, 16:56

eccolo

Codice: Seleziona tutto

# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>

pkgname=gnome-session-properties
pkgver=3.10.0
pkgrel=1
pkgdesc="The GNOME Session Properties Tool"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL')
depends=('gtk3' 'hicolor-icon-theme' 'dbus-glib')
makedepends=('gnome-common' 'gtk-doc' 'intltool')
options=('!emptydirs')
install=gnome-session.install
url="http://www.gnome.org"
source=("http://ftp.gnome.org/pub/gnome/sources/gnome-session/${pkgver%.*}/gnome-session-${pkgver}.tar.xz"
        '0001-Remove-unneeded-stuff.patch')
sha512sums=('036adc7ecff7f5aa1319bfac636b6b77925c689cb92880224cf665456dca5a55299025971a2bcdb841e27334ddc0cd6125241b39e48a30c3cc0b02c22612f5c9'
            '5b7f17d2b9499a43f3735732903b877d7af6e10c7e59f5658058288018a964ae0037fbd6ff84310e4251e80571390405d6c7e3d08edaa6c4c80e5906fce4bae6')

prepare() {
  cd "${srcdir}/gnome-session-${pkgver}"
  patch -p1 -i "${srcdir}/0001-Remove-unneeded-stuff.patch"
}

build() {
  cd "${srcdir}/gnome-session-${pkgver}"
  autoreconf -vfi
  ./configure --prefix=/usr
  make
}

package() {
  cd "${srcdir}/gnome-session-${pkgver}"
  make DESTDIR="${pkgdir}" install

  files=$(find "${pkgdir}" -name session-properties.png -o -name session-properties.svg)
  for f in ${files}; do
    mv "${f}" "${f/apps\/session-/apps\/gnome-session-}"
  done

  sed -ri '/^Icon/ s/session-/gnome-session-/g' \
    "${pkgdir}/usr/share/applications/gnome-session-properties.desktop"
}

# vim:set ts=2 sw=2 et:
comunque mi succede con qualsiasi programma io tenti di installare da AUR


ma com'è possibile che non trovi gtk3?

Codice: Seleziona tutto

...
checking what language compliance flags to pass to the C compiler... 
checking for GIO... yes
checking for GTK3... no
configure: error: Package requirements (gtk+-3.0 >= 2.90.7) were not met:

Package 'egl', required by 'cairo', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK3_CFLAGS
and GTK3_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
==> ERRORE: Makepkg non è riuscito a compilare gnome-session-properties.
==> Riavviare la compilazione di gnome-session-properties [s/N]
...

Avatar utente
gargamella
Arciere Provetto
Messaggi: 376
Iscritto il: 30 agosto 2009, 14:53

Re: problemi con yaourt (cairo?)

Messaggio da gargamella » 23 aprile 2014, 10:22

nessuno?

Avatar utente
TheSaint
Robin Hood
Messaggi: 7959
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: problemi con yaourt (cairo?)

Messaggio da TheSaint » 23 aprile 2014, 11:36

T' ha furia? :)
Forse è un problema con PKG_CONFIG_PATH.
Vedi se hai installato pkgconfig.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Avatar utente
gargamella
Arciere Provetto
Messaggi: 376
Iscritto il: 30 agosto 2009, 14:53

Re: problemi con yaourt (cairo?)

Messaggio da gargamella » 23 aprile 2014, 11:38

TheSaint ha scritto:T' ha furia? :)
Forse è un problema con PKG_CONFIG_PATH.
Vedi se hai installato pkgconfig.

si cè...
pacman -Q pkg-config
pkg-config 0.28-1

Avatar utente
gargamella
Arciere Provetto
Messaggi: 376
Iscritto il: 30 agosto 2009, 14:53

Re: problemi con yaourt (cairo?)

Messaggio da gargamella » 23 aprile 2014, 11:48

ho dato:

Codice: Seleziona tutto

export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"
e controllato con

Codice: Seleziona tutto

echo $PKG_CONFIG_PATH
/usr/local/lib/pkgconfig
come faccio ad aggiungerne altre? tipo /usr/lib/pkgconfig

Avatar utente
TheSaint
Robin Hood
Messaggi: 7959
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: problemi con yaourt (cairo?)

Messaggio da TheSaint » 23 aprile 2014, 11:51

hai gli stessi problemi se provi con makepkg PKGBUILD ?
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Avatar utente
gargamella
Arciere Provetto
Messaggi: 376
Iscritto il: 30 agosto 2009, 14:53

Re: problemi con yaourt (cairo?)

Messaggio da gargamella » 23 aprile 2014, 12:50

TheSaint ha scritto:hai gli stessi problemi se provi con makepkg PKGBUILD ?
si, appena provato

Codice: Seleziona tutto

[pablo@archlinux gnome-session-properties]$ makepkg PKGBUILD
==> Creazione del pacchetto: gnome-session-properties 3.10.0-1 (mer 23 apr 2014, 12.48.56, CEST)
==> Controllo delle dipendenze durante l'avvio in corso...
==> Controllo delle dipendenze durante la compilazione in corso...
==> Download dei sorgenti in corso...
  -> È stato trovato gnome-session-3.10.0.tar.xz
  -> È stato trovato 0001-Remove-unneeded-stuff.patch
==> Validazione dei sorgenti con sha512sums in corso...
    gnome-session-3.10.0.tar.xz ... Verificato
    0001-Remove-unneeded-stuff.patch ... Verificato
==> Estrazione dei sorgenti in corso...
  -> Estrazione di gnome-session-3.10.0.tar.xz con bsdtar in corso...
==> Avvio di prepare() in corso...
patching file Makefile.am
patching file capplet/Makefile.am
patching file config.h.in
patching file configure.ac
patching file data/Makefile.am
patching file data/gnome-custom-session.desktop.in
patching file data/gnome-dummy.session.desktop.in.in
patching file data/gnome-session.convert
patching file data/gnome-wayland.desktop.in
patching file data/gnome-wayland.session.desktop.in.in
patching file data/gnome.desktop.in
patching file data/gnome.session.desktop.in.in
patching file data/hardware-compatibility
patching file data/org.gnome.SessionManager.gschema.xml.in
patching file data/session-selector.ui
patching file doc/Makefile.am
patching file doc/dbus/Makefile.am
patching file doc/dbus/Makefile.in
patching file doc/dbus/config.xsl
patching file doc/dbus/dbus-introspect-docs.dtd
patching file doc/dbus/docbook.css
patching file doc/dbus/gnome-session.xml.in
patching file doc/dbus/spec-to-docbook.xsl
patching file doc/man/Makefile.am
patching file doc/man/gnome-session-inhibit.1
patching file doc/man/gnome-session-inhibit.xml
patching file doc/man/gnome-session-quit.1
patching file doc/man/gnome-session-selector.xml
patching file doc/man/gnome-session.1
patching file egg/Makefile.am
patching file egg/Makefile.in
patching file egg/eggdesktopfile.c
patching file egg/eggdesktopfile.h
patching file egg/eggsmclient-private.h
patching file egg/eggsmclient-xsmp.c
patching file egg/eggsmclient.c
patching file egg/eggsmclient.h
patching file gnome-session/Makefile.am
patching file gnome-session/README
patching file gnome-session/gdm-log.c
patching file gnome-session/gdm-log.h
patching file gnome-session/gsm-app.c
patching file gnome-session/gsm-app.h
patching file gnome-session/gsm-autostart-app.c
patching file gnome-session/gsm-autostart-app.h
patching file gnome-session/gsm-client.c
patching file gnome-session/gsm-client.h
patching file gnome-session/gsm-consolekit.c
patching file gnome-session/gsm-consolekit.h
patching file gnome-session/gsm-dbus-client.c
patching file gnome-session/gsm-dbus-client.h
patching file gnome-session/gsm-fail-whale-dialog.c
patching file gnome-session/gsm-fail-whale-dialog.h
patching file gnome-session/gsm-fail-whale.c
patching file gnome-session/gsm-fail-whale.h
patching file gnome-session/gsm-icon-names.h
patching file gnome-session/gsm-inhibitor-flag.h
patching file gnome-session/gsm-inhibitor.c
patching file gnome-session/gsm-inhibitor.h
patching file gnome-session/gsm-manager-logout-mode.h
patching file gnome-session/gsm-manager.c
patching file gnome-session/gsm-manager.h
patching file gnome-session/gsm-presence-flag.h
patching file gnome-session/gsm-presence.c
patching file gnome-session/gsm-presence.h
patching file gnome-session/gsm-process-helper.c
patching file gnome-session/gsm-process-helper.h
patching file gnome-session/gsm-session-fill.c
patching file gnome-session/gsm-session-fill.h
patching file gnome-session/gsm-session-save.c
patching file gnome-session/gsm-session-save.h
patching file gnome-session/gsm-shell-extensions.c
patching file gnome-session/gsm-shell-extensions.h
patching file gnome-session/gsm-shell.c
patching file gnome-session/gsm-shell.h
patching file gnome-session/gsm-store.c
patching file gnome-session/gsm-store.h
patching file gnome-session/gsm-system.c
patching file gnome-session/gsm-system.h
patching file gnome-session/gsm-systemd.c
patching file gnome-session/gsm-systemd.h
patching file gnome-session/gsm-xsmp-client.c
patching file gnome-session/gsm-xsmp-client.h
patching file gnome-session/gsm-xsmp-server.c
patching file gnome-session/gsm-xsmp-server.h
patching file gnome-session/main.c
patching file gnome-session/org.gnome.SessionManager.App.xml
patching file gnome-session/org.gnome.SessionManager.Client.xml
patching file gnome-session/org.gnome.SessionManager.ClientPrivate.xml
patching file gnome-session/org.gnome.SessionManager.Inhibitor.xml
patching file gnome-session/org.gnome.SessionManager.Presence.xml
patching file gnome-session/org.gnome.SessionManager.xml
patching file gnome-session/test-client-dbus.c
patching file gnome-session/test-inhibit.c
patching file gnome-session/test-process-helper.c
patching file po/POTFILES.in
patching file po/POTFILES.skip
patching file tools/Makefile.am
patching file tools/Makefile.in
patching file tools/gnome-session-check-accelerated-common.h
patching file tools/gnome-session-check-accelerated-helper.c
patching file tools/gnome-session-check-accelerated.c
patching file tools/gnome-session-custom-session
patching file tools/gnome-session-inhibit.c
patching file tools/gnome-session-quit.c
patching file tools/gnome-session-selector.c
==> Rimozione dell'esistente directory pkg/ in corso...
==> Avvio di build() in corso...
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4 ${ACLOCAL_FLAGS}
autoreconf: configure.ac: tracing
autoreconf: running: libtoolize --copy --force
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
libtoolize: copying file `m4/libtool.m4'
libtoolize: copying file `m4/ltoptions.m4'
libtoolize: copying file `m4/ltsugar.m4'
libtoolize: copying file `m4/ltversion.m4'
libtoolize: copying file `m4/lt~obsolete.m4'
autoreconf: running: /usr/bin/autoconf --force
autoreconf: running: /usr/bin/autoheader --force
autoreconf: running: automake --add-missing --copy --force-missing
autoreconf: Leaving directory `.'
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/sbin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether UID '1000' is supported by ustar format... yes
checking whether GID '100' is supported by ustar format... yes
checking how to create a ustar tar archive... gnutar
checking whether make supports nested variables... (cached) yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for glib-genmarshal... /usr/sbin/glib-genmarshal
checking for pkg-config... /usr/sbin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking how to print strings... printf
checking for a sed that does not truncate output... /usr/sbin/sed
checking for grep that handles long lines and -e... /usr/sbin/grep
checking for egrep... /usr/sbin/grep -E
checking for fgrep... /usr/sbin/grep -F
checking for ld used by gcc... /usr/sbin/ld
checking if the linker (/usr/sbin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/sbin/nm -B
checking the name lister (/usr/sbin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert x86_64-unknown-linux-gnu file names to x86_64-unknown-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-unknown-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/sbin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/sbin/nm -B output from gcc object... ok
checking for sysroot... no
checking for mt... no
checking if : is a manifest tool... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/sbin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for shl_load... no
checking for shl_load in -ldld... no
checking for dlopen... no
checking for dlopen in -ldl... yes
checking whether a program can dlopen itself... yes
checking whether a statically linked program can dlopen itself... no
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether gcc understands -Wall... yes
checking whether gcc understands -Wstrict-prototypes... yes
checking whether gcc understands -Wnested-externs... yes
checking whether gcc understands -Werror=missing-prototypes... yes
checking whether gcc understands -Werror=implicit-function-declaration... yes
checking whether gcc understands -Werror=pointer-arith... yes
checking whether gcc understands -Werror=init-self... yes
checking whether gcc understands -Werror=format-security... no
checking whether gcc understands -Werror=format=2... yes
checking whether gcc understands -Werror=missing-include-dirs... yes
checking what warning flags to pass to the C compiler...  -Wall -Wstrict-prototypes -Wnested-externs -Werror=missing-prototypes -Werror=implicit-function-declaration -Werror=pointer-arith -Werror=init-self -Werror=format=2 -Werror=missing-include-dirs
checking what language compliance flags to pass to the C compiler... 
checking for GIO... yes
checking for GTK3... no
configure: error: Package requirements (gtk+-3.0 >= 2.90.7) were not met:

Package 'egl', required by 'cairo', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK3_CFLAGS
and GTK3_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
[pablo@archlinux gnome-session-properties]$ 

Avatar utente
gargamella
Arciere Provetto
Messaggi: 376
Iscritto il: 30 agosto 2009, 14:53

Re: problemi con yaourt (cairo?)

Messaggio da gargamella » 23 aprile 2014, 13:15

non capisco. allora ho provato a compilare gnome-initial-setup

Codice: Seleziona tutto

...
checking pkg-config is at least version 0.9.0... yes
checking for INITIAL_SETUP... no
configure: error: Package requirements (NetworkManager >= 0.9.6.4
                  libnm-glib >= 0.9.6.4
                  libnm-util >= 0.9.6.4
                  libnm-gtk >= 0.9.6.4
                  polkit-gobject-1 >= 0.103
                  accountsservice
                  gnome-desktop-3.0 >= 3.7.5
                  gstreamer-1.0
                  fontconfig
                  gweather-3.0
                  goa-1.0
                  goa-backend-1.0
                  gtk+-3.0 >= 3.7.11
                  gio-unix-2.0 >= 2.36.0
                  gdm >= 3.8.3
                  pango >= 1.32.5
                  pwquality
                  egg-list-box-uninstalled) were not met:

Package 'glesv2', required by 'cairo', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables INITIAL_SETUP_CFLAGS
and INITIAL_SETUP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
==> ERRORE: Makepkg non è riuscito a compilare gnome-initial-setup.
==> Riavviare la compilazione di gnome-initial-setup [s/N]
...
e mi dice che non trova "glesv2" richiesto da cairo, però se do:

Codice: Seleziona tutto

[pablo@archlinux ~]$ locate pkgconfig | grep glesv2
/usr/local/lib/pkgconfig/cairo-glesv2.pc
[pablo@archlinux ~]$
me lo trova...
Ma cosa c***o vuole?

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Re: problemi con yaourt (cairo?)

Messaggio da Hilinus » 23 aprile 2014, 18:53

Perchè la roba di cairo sta in /usr/local? Hai provato percaso a compilarlo manualmente?

Posta:

Codice: Seleziona tutto

find /usr/local
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Avatar utente
gargamella
Arciere Provetto
Messaggi: 376
Iscritto il: 30 agosto 2009, 14:53

Re: problemi con yaourt (cairo?)

Messaggio da gargamella » 23 aprile 2014, 22:33

Hilinus ha scritto:Perchè la roba di cairo sta in /usr/local? Hai provato percaso a compilarlo manualmente?

Posta:

Codice: Seleziona tutto

find /usr/local
no, l'ho installato con pacman.....
aspetta, forse avevo tentato di compilare la versione da git (ma si bloccava anch'essa)
comunque,ecco qui

Codice: Seleziona tutto

[pablo@archlinux ~]$ find /usr/local
/usr/local
/usr/local/games
/usr/local/share
/usr/local/share/man
/usr/local/usbformatter
/usr/local/usbformatter/__pycache__
/usr/local/usbformatter/__pycache__/usbformatter_ui.cpython-34.pyc
/usr/local/usbformatter/usbformatter_ui.py
/usr/local/usbformatter/usbformatter.py
/usr/local/usbformatter/images
/usr/local/usbformatter/images/usb-usbformatter.png
/usr/local/usbformatter/images/loading.gif
/usr/local/include
/usr/local/include/cairo
/usr/local/include/cairo/cairo-gobject.h
/usr/local/include/cairo/cairo.h
/usr/local/include/cairo/cairo-pdf.h
/usr/local/include/cairo/cairo-features.h
/usr/local/include/cairo/cairo-ft.h
/usr/local/include/cairo/cairo-ps.h
/usr/local/include/cairo/cairo-xlib.h
/usr/local/include/cairo/cairo-version.h
/usr/local/include/cairo/cairo-xlib-xrender.h
/usr/local/include/cairo/cairo-script-interpreter.h
/usr/local/include/cairo/cairo-script.h
/usr/local/include/cairo/cairo-svg.h
/usr/local/include/cairo/cairo-deprecated.h
/usr/local/include/cairo/cairo-gl.h
/usr/local/src
/usr/local/etc
/usr/local/bin
/usr/local/bin/cairo-trace
/usr/local/man
/usr/local/lib
/usr/local/lib/libcairo-gobject.la
/usr/local/lib/libcairo.a
/usr/local/lib/libcairo-script-interpreter.a
/usr/local/lib/cairo
/usr/local/lib/cairo/libcairo-trace.so.0.0.0
/usr/local/lib/cairo/libcairo-trace.a
/usr/local/lib/cairo/libcairo-trace.la
/usr/local/lib/cairo/libcairo-trace.so.0
/usr/local/lib/cairo/libcairo-trace.so
/usr/local/lib/libcairo.so.2.11301.0
/usr/local/lib/libcairo.la
/usr/local/lib/libcairo.so
/usr/local/lib/libcairo-gobject.so
/usr/local/lib/libcairo-gobject.so.2.11301.0
/usr/local/lib/libcairo-script-interpreter.so.2.11301.0
/usr/local/lib/pkgconfig
/usr/local/lib/pkgconfig/cairo-script.pc
/usr/local/lib/pkgconfig/cairo-gobject.pc
/usr/local/lib/pkgconfig/cairo-png.pc
/usr/local/lib/pkgconfig/cairo-glesv2.pc
/usr/local/lib/pkgconfig/cairo-xlib-xrender.pc
/usr/local/lib/pkgconfig/cairo-svg.pc
/usr/local/lib/pkgconfig/cairo-fc.pc
/usr/local/lib/pkgconfig/cairo-pdf.pc
/usr/local/lib/pkgconfig/cairo.pc
/usr/local/lib/pkgconfig/cairo-ft.pc
/usr/local/lib/pkgconfig/cairo-egl.pc
/usr/local/lib/pkgconfig/cairo-xlib.pc
/usr/local/lib/pkgconfig/cairo-ps.pc
/usr/local/lib/libcairo-script-interpreter.so
/usr/local/lib/libcairo.so.2
/usr/local/lib/libcairo-gobject.a
/usr/local/lib/libcairo-script-interpreter.so.2
/usr/local/lib/libcairo-gobject.so.2
/usr/local/lib/libcairo-script-interpreter.la
/usr/local/sbin

Avatar utente
gargamella
Arciere Provetto
Messaggi: 376
Iscritto il: 30 agosto 2009, 14:53

Re: problemi con yaourt (cairo?)

Messaggio da gargamella » 24 aprile 2014, 0:43

dovrei aver risolto. Ho reinstallato tutti i pacchetti con

Codice: Seleziona tutto

sudo pacman -S $(pacman -Qq | grep -v "$(pacman -Qmq)")
"appena" 6 Gb di roba.... :shock:
Speriamo bene.

Grazie a tutti per l'appoggio

Rispondi