[Risolto] Problema aggiornamento Libreoffice common+poppler

Problemi e suggerimenti legati al software e ai pacchetti problematici.
Rispondi
manu79
Arciere
Messaggi: 154
Iscritto il: 30 aprile 2013, 13:16

[Risolto] Problema aggiornamento Libreoffice common+poppler

Messaggio da manu79 » 6 agosto 2013, 9:39

Salve a tutti. Utilizzo Arch+KDE da tre mesi circa e ne sono entusiasta. Ieri ho cercato di aggiornare il sistema (lo faccio regolarmente ogni 24/48 ore circa) ma è sorto un problema coi pacchetto Libreoffice common e con i pacchetti poppler e poppler-glib a causa di una dipendenza. Il messaggio che mi esce quando cerco di avviare l'aggiornamento è il seguente:

Impossibile trovare una dipendenza pacchetto.
Sono disponibile maggiori informazioni nel rapporto dettagliato.

poppler=0.22.5 <- poppler-qt: could not satisfy dependencies

Da cosa può dipendere?
Ultima modifica di manu79 il 6 agosto 2013, 19:16, modificato 1 volta in totale.

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Re: Problema aggiornamento Libreoffice common+poppler

Messaggio da Hilinus » 6 agosto 2013, 10:36

poppler-qt è stato rinominato in poppler-qt4, probabilmente per l'aggiunta del relativo pacchetto per qt5. Aspetta che aggiornino anche libreoffice ed eventuali altri pacchetti collegati.
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Asa
Arciere Provetto
Messaggi: 456
Iscritto il: 3 giugno 2009, 14:53
Località: Milano
Contatta:

Re: Problema aggiornamento Libreoffice common+poppler

Messaggio da Asa » 6 agosto 2013, 11:32

Anch'io ho avuto lo stesso problema visto che, come ha detto Hilinus, poppler è stato rinominato ho aggiornato con l'opzione -Sud senza problemi.

manu79
Arciere
Messaggi: 154
Iscritto il: 30 aprile 2013, 13:16

Re: [Risolto] Problema aggiornamento Libreoffice common+poppler

Messaggio da manu79 » 6 agosto 2013, 19:18

Grazie ad entrambi Hilinus e Asa. Ho dato il comando pacman -Sud e sia libreoffice common sia poppler-qt si sono aggiornati senza problemi. Avrei una curiosità: cosa fà nel dettaglio l'opzione - Sud di pacman?
Grazie ancora. Messo risolto al thread

Asa
Arciere Provetto
Messaggi: 456
Iscritto il: 3 giugno 2009, 14:53
Località: Milano
Contatta:

Re: [Risolto] Problema aggiornamento Libreoffice common+poppler

Messaggio da Asa » 6 agosto 2013, 21:28

man pacman da la risposta molto più esaurientemente di me, a grandi linee -d indica di non curarsi delle dipendenze. In questo caso non si corre alcun rischio perchè le dipendenze vengono comunque soddisfatte dal pacchetto col nuovo nome.

Rispondi