Aggiornamento interrotto per pacchetto non valido o corrotto

Tutto ciò che altrimenti sarebbe OT
Rispondi
vioma
Newbie
Messaggi: 6
Iscritto il: 30 giugno 2014, 23:10

Aggiornamento interrotto per pacchetto non valido o corrotto

Messaggio da vioma » 19 ottobre 2014, 9:31

Buongiorno,
stamattina volevo aggiornare il sistema, ma non mi è stato possibile perchè ad un certo punto mi spuntano i seguenti errori:

Codice: Seleziona tutto

errore: lightdm-webkit-theme-antergos: signature from "Antergos Build Server (Automated Package Build System) <admin@antergos.org>" is marginal trust
:: Il file /var/cache/pacman/pkg/lightdm-webkit-theme-antergos-2.0.6-1-any.pkg.tar.xz è corrotto (il pacchetto non è valido oppure è corrotto (firma PGP)).
Vuoi eliminarlo? [S/n] n
errore: numix-icon-theme: signature from "Antergos Build Server (Automated Package Build System) <admin@antergos.org>" is marginal trust
:: Il file /var/cache/pacman/pkg/numix-icon-theme-0.r219.9e882fa-1-any.pkg.tar.xz è corrotto (il pacchetto non è valido oppure è corrotto (firma PGP)).
Vuoi eliminarlo? [S/n] n
errore: numix-icon-theme-square: signature from "Antergos Build Server (Automated Package Build System) <admin@antergos.org>" is marginal trust
:: Il file /var/cache/pacman/pkg/numix-icon-theme-square-1:0.r74.f1b7833-1-any.pkg.tar.xz è corrotto (il pacchetto non è valido oppure è corrotto (firma PGP)).
Vuoi eliminarlo? [S/n] n
errore: impossibile eseguire l'operazione richiesta (il pacchetto non è valido oppure è corrotto)
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
[root@fenix Scaricati]#
sia che do il consenso, sia che lo neghi, non riesco ad andare avanti.
Mi guidate nella soluzione del problema?

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Aggiornamento interrotto per pacchetto non valido o corrotto

Messaggio da 4javier » 19 ottobre 2014, 13:50

Sposto in Altro. Questo è il forum di Archlinux. Per supporto inerente altre distribuzioni, anche se derivate, sarebbe più conveniente rivolgersi al forum appropriato. In ogni caso, se si volesse postare comunque qui, ricordarsi di postare nella sezione Altro e SPECIFICARE SEMPRE CHE SI STA USANDO UNA DISTRO DIFFERENTE DA ARCHLINUX.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

vioma
Newbie
Messaggi: 6
Iscritto il: 30 giugno 2014, 23:10

Re: Aggiornamento interrotto per pacchetto non valido o corrotto

Messaggio da vioma » 19 ottobre 2014, 14:10

Premesso che chiedo scusa se ho pubblicato su una sezione del forum non approrpriata, gradirei che se mi si dovesse indicare una procedura non approprieata lo si facesse senza "GRIDARE".
Ciò premesso penso che una comunità prescinda da una derivata (posso pure sbagliarmi) ma abbia interesse a perseguire lo spirirto della comunità stessa, in questo caso la diffusione di una distribuzione. Per l'appunto è un problema che non ha nulla a che fare con la derivata, ma ad un blocco di Pacman per un motivo che non sono riuscito a risolvere e che nulla ha a che fare con la derivata.
In ogni caso, installazione e qualche effetto grafico a parte, Antergos è quasi identica a ArchLinux e i comandi sono "esattamente" quelli utilizzati per ArchLinux.
Grazie anticipato per gli aiuti che "spero" arrivino.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Aggiornamento interrotto per pacchetto non valido o corrotto

Messaggio da TheSaint » 19 ottobre 2014, 15:00

Se è un flame che vuoi allora cominciamo.
  1. A dispetto di altri forum, come p.es bbs.archlinux.org, qui si tollerano le derivate
  2. Hai provato in un forum di debian chiedere di ubuntu?
  3. Mi par anche evidente che i files non corrispondono alla firma. Potrebbe essere che trovi altro mirror più aggiornato oppure il pacchetto è in lista nera
  4. Hai provato ad installare una Arch, magari non causa a qualcuno di malumore di gridare. Si può anche partire dalla distro che hai e installare in differita.
  5. Se questo non ti piace, magari prova sul forum di Antergos. Qui si aiuta quelli che non antepongono arroganze.
Al punto c hai la risposta che cerchi.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

vioma
Newbie
Messaggi: 6
Iscritto il: 30 giugno 2014, 23:10

Re: Aggiornamento interrotto per pacchetto non valido o corrotto

Messaggio da vioma » 19 ottobre 2014, 16:04

La risposta, a parte il punto c che non mi spiega come andare avanti e forzare il controllo, è stata data quanto meno senza gridare.
Se si utilizzassero le energie per dare le risposte ai problemi anzicchè esaurirle nelle polemiche, certamente si rappresenterebbe meglio il concetto di "comunità libera".
Solo per chiarire a scanso di equivoci, la comunità Debianizzati risponde a richieste su Ubuntu e derivate Debian, senza spostare nulla.
In ogni caso esiste un forum di Ubuntu che non ti da la necessità di cihiedere altrove, per le sue derivate.
Per il resto nessuna arroganza, se conoscevo la lingua inglese, mi sarei già iscritto a quello di Antergos. Ho posto altre domande su questo forum credendo di poterlo fare senza spiegare che ho una derivata.
Ti ringrazio per avermi avvertito che di risposte, a questo problema, non ne arriveranno più.
Grazie comunque per il tempo che hai "perso".

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: Aggiornamento interrotto per pacchetto non valido o corrotto

Messaggio da pineout » 21 ottobre 2014, 13:46

vioma io ti consiglio di disabilitare il repo di antergos, funzionera' tutto normalmente (gia' testato)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Aggiornamento interrotto per pacchetto non valido o corrotto

Messaggio da TheSaint » 22 ottobre 2014, 15:24

Se vuoi un aiuto rimaniamo sul discorso di ciò che ti serve.
Ci sono 2 opzioni
  1. Rimovi i pacchetti e riprovi a scaricare
  2. Disabiliti la verifica delle firme dei pacchetti in pacman.conf, magari relativo a quel repositorio.
  3. Oppure entrambe
Posta /etc/pacman.conf
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Rispondi