[Risolto] XFCE e layout di tastiera

Avvio e configurazione del server X, KDE, GNOME e tutti gli altri DE/WM
Rispondi
Avatar utente
crx
Arciere
Messaggi: 235
Iscritto il: 9 febbraio 2009, 14:33

Messaggio da crx » 11 febbraio 2009, 18:17

Scusate ragazzi ma non c'e' un modo per impostare la tastiera italiana con XFCE?
Ho provato in diversi modi, ma proprio non riesco.
Grazie!
Ultima modifica di crx il 12 febbraio 2009, 7:37, modificato 1 volta in totale.
S = k ln W
Il mio nome è Bond. Valence Bond. - Se non fai parte della soluzione, fai parte del precipitato.

Biagio
Arciere Provetto
Messaggi: 730
Iscritto il: 26 febbraio 2008, 17:21
Località: Firenze

Messaggio da Biagio » 11 febbraio 2009, 19:40

Dire che hai provato in molti modi non aiuta molto a capire cosa suggerirti.
Comunque, hai lasciato il controllo della tastiera a xorg o ad hal?
Per esempio, hai in xorg.conf una sezione del genere (vorrebbe dire che lo hai lasciato ad xorg)?

Section "ServerFlags"
Option "AutoAddDevices" "False"
EndSection

Avatar utente
crx
Arciere
Messaggi: 235
Iscritto il: 9 febbraio 2009, 14:33

Messaggio da crx » 11 febbraio 2009, 20:05

Hai ragione, scusa, non ho dato molti indizi.

Dunque, ho provato a modificare lo xorg cosi'

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "it"
EndSection

(di default ho solo le prime due righe).
Ho anche provato ad aggiungere

Option "XkbMode" "pc105"

Da qualche parte, poi, ho trovato uno che diceva che occorreva dare un

export LC_ALL=it_IT

prima di avviare XFCE. L'ho fatto sia direttamente, cioe' con quel comando e poi con startx, che modificando il file .xinitrc, ma niente.


Per quanto riguarda lo xorg, ho la sezione che dici ma c'e' solo

Section "ServerFlags"
Option "Xinerama" "on"
EndSection

(ho abilitato il doppio monitor con i driver ATI).
Hal ce l'ho, ovviamente, ma non so vedere se ha il controllo della tastiera.
Comunque sia da shell che con Gnome la tastiera e' italiana, con XFCE e LXDE no.

Ho visto che nel menu' Impostazioni > Impostazioni della tastiera c'e' una sezione "Mappa della tastiera", ma ce n'e' solo una (Emacs), e non so come aggiungerne altre.
Grazie per la pazienza!
S = k ln W
Il mio nome è Bond. Valence Bond. - Se non fai parte della soluzione, fai parte del precipitato.

Biagio
Arciere Provetto
Messaggi: 730
Iscritto il: 26 febbraio 2008, 17:21
Località: Firenze

Messaggio da Biagio » 12 febbraio 2009, 0:28

Prova a creare il file /etc/hal/fdi/policy/10-keymap.fdi
e a incollarci questo dentro:

Codice: Seleziona tutto

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>
    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>
      <merge key="input.xkb.layout" type="string">it</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>
In xorg.conf NON ci deve essere la riga:
Option "AutoAddDevices" "False"
Così togli a xorg il controllo della tastiera e lo lasci invece ad hal.

Poi riavvia.
Se funziona, puoi anche cancellare (se vuoi) da xorg.conf le voci relative alla tastiera.

Avatar utente
crx
Arciere
Messaggi: 235
Iscritto il: 9 febbraio 2009, 14:33

Messaggio da crx » 12 febbraio 2009, 7:37

§àèéìòù :D

Grande! Funziona perfettamente! Sarà stata una stupidata, ma non poter scrivere le vocali accentate a volte può diventare davvero un problema.

Ti ringrazio!
S = k ln W
Il mio nome è Bond. Valence Bond. - Se non fai parte della soluzione, fai parte del precipitato.

Rispondi