Xfce4 Modificare tema

Avvio e configurazione del server X, KDE, GNOME e tutti gli altri DE/WM
Rispondi
giuseppe
Novello Arciere
Messaggi: 64
Iscritto il: 30 ottobre 2008, 13:28

Messaggio da giuseppe » 17 dicembre 2008, 1:56

Ciao!!!
Ho installato un tema per xfce4 molto carino, ma ha l'unico incoveniente che quando devo settare qualcosa in qualche finestra il testo che seleziono diventa bianco, ma bianco è anche lo sfondo quindi diventa inleggibile.... Mi sapete dire come posso modificare il colore del testo quando viene selezionato???

Poi ho anche un altro problema quando compare il menu a tendina di xfce questo è tutto sgranto per un istante e poi si vede normale, come posso eliminare questo sgradevole effetto???

pikiweb
Arciere
Messaggi: 341
Iscritto il: 11 aprile 2008, 14:30
Località: Torino

Messaggio da pikiweb » 17 dicembre 2008, 12:11

per il primo problema, devi modificare il gtkrc del tema (si trova nella cartella gtk-2.0 della cartella del tema..)..dando uno sguardo da profano che sono, direi che dovresti cambiare le righe che cominciano con "text" (vedo text[NORMAL], prelight, active, selected..)
al limite guarda qualche howto per i temi, se così non ne vieni a capo

l'altra cosa succedeva anche a me, credo dipenda dalle impostazioni di xorg.conf..

giuseppe
Novello Arciere
Messaggi: 64
Iscritto il: 30 ottobre 2008, 13:28

Messaggio da giuseppe » 17 dicembre 2008, 15:39

grazie per la risposta...

Ma tu l'hai risolto il problema??????? Perchè io nell'xorg ho attivato l'accelerazione è basta... non saprei proprio dove mettere le mani per risolverlo!!!

Avatar utente
pierluigi
Amministratore
Messaggi: 1204
Iscritto il: 26 agosto 2007, 15:39

Messaggio da pierluigi » 17 dicembre 2008, 20:02

giuseppe ha scritto:Ma tu l'hai risolto il problema??????? Perchè io nell'xorg ho attivato l'accelerazione è basta... non saprei proprio dove mettere le mani per risolverlo!!!
credo che a me lo facesse con il composite attivo.
l'ho disabilitato.

giuseppe
Novello Arciere
Messaggi: 64
Iscritto il: 30 ottobre 2008, 13:28

Messaggio da giuseppe » 17 dicembre 2008, 21:56

In effetti ho tolto i driver ati è il problema non si è più presentato.....
Ma secondo voi faccio bene a toglierli???

Avatar utente
pierluigi
Amministratore
Messaggi: 1204
Iscritto il: 26 agosto 2007, 15:39

Messaggio da pierluigi » 17 dicembre 2008, 23:57

giuseppe ha scritto:In effetti ho tolto i driver ati è il problema non si è più presentato.....
Ma secondo voi faccio bene a toglierli???
mah! al limite disattiva il composite

Aggiungi dove vuoi (anche alla fine) in xorg.conf

Section "Extensions"
Option "Composite" "Disable"
EndSection

giuseppe
Novello Arciere
Messaggi: 64
Iscritto il: 30 ottobre 2008, 13:28

Messaggio da giuseppe » 18 dicembre 2008, 10:11

No... Perchè io sono un po fissato, con avere un ambiente grafico carino e quindi voglio a tutti i costi la shell trasparente, se lo disabilito la trasparenza fa pena!!!

giuseppe
Novello Arciere
Messaggi: 64
Iscritto il: 30 ottobre 2008, 13:28

Messaggio da giuseppe » 22 dicembre 2008, 22:09

dunque io ho provato a modificare il codice del file ma non cambia mai niente non è che devo fare qualcosa altro oltre a modificare??

il codice che modifico è questo :

Codice: Seleziona tutto

style "default"
{
    GtkMenuBar::internal-padding = 5
  
    bg_pixmap[NORMAL] = "background.png"

    fg[PRELIGHT]    = { 1.00, 1.00, 1.00 }
    fg[ACTIVE]      = { 0.00, 0.00, 0.00 }
    fg[SELECTED]    = { 0.00, 0.00, 0.00 }
    fg[INSENSITIVE] = { 0.70, 0.70, 0.70 }

    bg[NORMAL]      = "#ffffff"
    bg[PRELIGHT]    = "#ffffff"
    bg[ACTIVE]      = "#ffffff"
    bg[INSENSITIVE] = "#ffffff"
    bg[SELECTED]    = "#1376d3"

    base[NORMAL]    = "#ffffff"
    base[SELECTED]  = "#1376d3"
    base[ACTIVE]    = "#5e7ab7"
#ho modificato qui
    text[SELECTED]  = "#ffffff"
    text[ACTIVE]    = "#ffffff"
Io impostavo il text[selected] con il colore nero 0000000

Rispondi