Suono al login di Gnome che non parte

Avvio e configurazione del server X, KDE, GNOME e tutti gli altri DE/WM
Rispondi
Avatar utente
fabrixx
Arciere
Messaggi: 150
Iscritto il: 1 maggio 2015, 11:38
Architettura: x86_64 (64bit)
Contatta:

Suono al login di Gnome che non parte

Messaggio da fabrixx » 23 maggio 2020, 18:03

Salve.

Vorrei riprodurre un suono al login di Gnome.

Ho configurato un tema sonoro personalizzato con file .oga in /usr/share/sound
Tutti i suoni degli eventi di sistema funzionano.


Se eseguo da terminale il comando:

Codice: Seleziona tutto

/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
Sento correttamente il suono.

Ho provato

1 - Creato un lanciatore con alacarte con il suddetto comando. Viene creato il lanciatore e il suono parte con un doppio clic. Ho aggiunto poi da Gnome Tweak il lanciatore alle applicazioni di avvio automarico ma al reboot nessun suono.


2 - Creato il file libcanberra-login-sound.desktop con:

Codice: Seleziona tutto

[Desktop Entry]
Type=Application
Name=GNOME Login Sound
Comment=Plays a sound whenever you log in
Exec=/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
OnlyShowIn=GNOME;Unity;
AutostartCondition=GSettings org.gnome.desktop.sound event-sounds
X-GNOME-Autostart-Phase=Application
X-GNOME-Autostart-Delay=10
X-GNOME-Provides=login-sound
X-GNOME-Autostart-enabled=true
NoDisplay=true
Aggiunto rispettivamente in /etc/xdg/autostart poi in /usr/share/gnome/autostart poi in ~/.config/autostart e riavviato il PC ad ogni tentativo senza sentire alcun suono. Ho settato i permessi del file sia root che utente ad ogni tentativo.

3 - Creato un file di testo con /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login" e rinominato loginsound.desktop, piazzato poi nelle suddette posizioni ma niente (provato anche a renderlo eseguibile).

4 - Impostato un delay con

Codice: Seleziona tutto

X-GNOME-Autostart-Delay=10
e riavviato ma niente.


Dove sto sbagliando?

Se eseguo quel comando da terminale sento correttamente il suono


EDIT: sono riuscito a far riprodurre il suono selezionando l'esecuzione da terminale:

Codice: Seleziona tutto

[Desktop Entry]
Name=Login sound
Exec=/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
Comment=
Terminal=true
Icon=gnome-panel-launcher
Type=Application
Non è bellissimo però vedere il terminale che si apre, poi esce il suono e si richiude...se si potesse evitare


Segnalo anche questa discussione:
https://archlinux.it/forum/viewtopic.php?t=17055

VenereNera
Little John
Messaggi: 953
Iscritto il: 20 dicembre 2012, 19:50

Re: Suono al login di Gnome che non parte

Messaggio da VenereNera » 25 maggio 2020, 21:56

Prova così:
In ~/.config/autostart:

Codice: Seleziona tutto

[Desktop Entry]
Type=Application
Name=GNOME Login Sound
Comment=Plays a sound whenever you log in
# Modifica il /percorso/file.oga
Exec=/usr/bin/canberra-gtk-play -f /nome/completo/file.oga
#
X-GNOME-Autostart-Phase=Application
X-GNOME-Provides=login-sound
X-GNOME-Autostart-enabled=true

Rispondi