[Risolto] Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Avvio e configurazione del server X, KDE, GNOME e tutti gli altri DE/WM
Rispondi
Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

[Risolto] Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Messaggio da Barone Rosso » 20 maggio 2015, 22:01

Eccola.

Aspetto disastroso.
Oltre ad essere poco usabile ed avere problemi coi widget ...

Come si può rimediare????

Immagine

Altre applicazioni GTK come Gimp vanno bene.
E su XFCE Pavucontrol 3.0 va perfettamente.
Ultima modifica di Barone Rosso il 21 maggio 2015, 16:42, modificato 1 volta in totale.

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Messaggio da 4javier » 21 maggio 2015, 16:19

lanciato da terminale non dà errori?
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

Re: Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Messaggio da Barone Rosso » 21 maggio 2015, 16:24

4javier ha scritto:lanciato da terminale non dà errori?
Da dei warning ...
Ma su xfce, dove funziona perfettamente, ci sono gli stessi warning.

Penso che sia un problema con KDE e col kde-gtk-config che a quanto pare è stato adattato a plasma 5; mentre al momento uso ancora il vecchio plasma 4.
Se c'è una soluzione di ripiego ...

Codice: Seleziona tutto

(pavucontrol:21359): GLib-GObject-WARNING **: The property GtkMisc:xpad is deprecated and shouldn't be used anymore. It will be removed in a future version.

(pavucontrol:21359): GLib-GObject-WARNING **: The property GtkMisc:ypad is deprecated and shouldn't be used anymore. It will be removed in a future version.

(pavucontrol:21359): GLib-GObject-WARNING **: The property GtkAlignment:bottom-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.

(pavucontrol:21359): GLib-GObject-WARNING **: The property GtkAlignment:left-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.

(pavucontrol:21359): GLib-GObject-WARNING **: The property GtkAlignment:right-padding is deprecated and shouldn't be used anymore. It will be removed in a future version.

(pavucontrol:21359): GLib-GObject-WARNING **: The property GtkContainer:resize-mode is deprecated and shouldn't be used anymore. It will be removed in a future version.

(pavucontrol:21359): GLib-GObject-WARNING **: The property GtkImage:stock is deprecated and shouldn't be used anymore. It will be removed in a future version.

(pavucontrol:21359): GLib-GObject-WARNING **: The property GtkButton:xalign is deprecated and shouldn't be used anymore. It will be removed in a future version.

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Messaggio da 4javier » 21 maggio 2015, 16:32

Che io sappia kde-gtk-config è solo un tool per configurare il tema gtk delle applicazioni. In pratica evita di mettere mano al .gtkrc di gtk2 ed al settings.ini di gtk3. Hai utenti separati KDE e XFCE?
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

Re: Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Messaggio da Barone Rosso » 21 maggio 2015, 16:38

4javier ha scritto:Che io sappia kde-gtk-config è solo un tool per configurare il tema gtk delle applicazioni. In pratica evita di mettere mano al .gtkrc di gtk2 ed al settings.ini di gtk3. Hai utenti separati KDE e XFCE?
No stessi utenti.

Risolto .....

Ho editato a mano il file ./.config/gtk-3.0/settings.ini
E ho messo come tema qtcurve-gtk ... e adesso funziona.

Ma il kde-gtk-config mi sa che adesso va solo con plasma 5

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: [Risolto] Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Messaggio da 4javier » 21 maggio 2015, 21:19

Ah, ma allora kde-gtk-config lo cambia al volo ogni volta che avvii kde, non apporta modifiche permanenti.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

Re: [Risolto] Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Messaggio da Barone Rosso » 22 maggio 2015, 10:08

4javier ha scritto:Ah, ma allora kde-gtk-config lo cambia al volo ogni volta che avvii kde, non apporta modifiche permanenti.
Non mi risulta visto che al riavvio tutto andava ... ma visto che al momento non uso plasma 5 non mi funziona neppure ... quindi tutto bene.

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: [Risolto] Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Messaggio da 4javier » 22 maggio 2015, 11:31

Appunto perchè non funziona su plasma4, ora lascia inalterate le impostazioni che hai settato manualmente.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
Pandino
Arciere
Messaggi: 273
Iscritto il: 28 marzo 2013, 18:01
Architettura: x86_64 (64bit)

Re: [Risolto] Pavucontrol 3 (GTK 3) su KDE ha una GUI che non funziona ...

Messaggio da Pandino » 31 maggio 2015, 21:29

È presente in AUR il pacchetto "kde-gtk-config-kde4".

Rispondi