Failed to open protocol names file lib/xorg/protocol.txt

Avvio e configurazione del server X, KDE, GNOME e tutti gli altri DE/WM
Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da 4javier » 4 gennaio 2019, 15:39

magellano ha scritto:
3 gennaio 2019, 21:37

Codice: Seleziona tutto

root:x:0:root
bin:x:1:root,bin,daemon
daemon:x:2:root,bin,daemon
sys:x:3:root,bin,angelo
adm:x:4:root,daemon
tty:x:5:
disk:x:6:root
lp:x:7:daemon,angelo
mem:x:8:
kmem:x:9:
wheel:x:10:root,angelo,ilaria,augusta
ftp:x:11:
mail:x:12:
uucp:x:14:
log:x:19:root
utmp:x:20:
locate:x:21:
rfkill:x:24:
smmsp:x:25:
proc:x:26:polkitd
http:x:33:
games:x:50:angelo
lock:x:54:
uuidd:x:68:
dbus:x:81:
network:x:90:angelo
video:x:91:angelo
audio:x:92:angelo
optical:x:93:
floppy:x:94:
storage:x:95:angelo
scanner:x:96:angelo
input:x:97:
power:x:98:
nobody:x:99:
users:x:100:
systemd-journal:x:190:
systemd-journal-gateway:x:191:
systemd-timesync:x:192:
systemd-network:x:193:
systemd-bus-proxy:x:194:
systemd-resolve:x:195:
systemd-journal-upload:x:998:
systemd-journal-remote:x:999:
avahi:x:84:
polkitd:x:102:
colord:x:124:
lxdm:x:121:
git:x:997:
usbmux:x:140:
systemd-coredump:x:996:
rtkit:x:133:
kvm:x:995:
render:x:994:
adbusers:x:993:
augusta:x:1002:
Il tuo utente principale è inserito in molti gruppi non più necessari, alcuni dei quali potrebbero addirittura creare problemi (ma non quelli che riscontri tu, quindi non credo sia questa la causa).
Posta per entrambe le sessioni mate, se riesci

Codice: Seleziona tutto

loginctl show-session $XDG_SESSION_ID
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

magellano
Novello Arciere
Messaggi: 147
Iscritto il: 10 settembre 2016, 9:44

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da magellano » 5 gennaio 2019, 12:58

loginctl show-session $XDG_SESSION_ID

la sessione ok

Codice: Seleziona tutto

Id=c1
User=1000
Name=angelo
Timestamp=Sat 2019-01-05 12:38:00 CET
TimestampMonotonic=33462109
VTNr=1
Seat=seat0
TTY=tty1
Display=:0
Remote=no
Service=lxdm
Scope=session-c1.scope
Leader=503
Audit=4294967295
Type=x11
Class=user
Active=yes
State=active
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
LockedHint=no
la sessione non ok, ma comando dato da tty

Codice: Seleziona tutto

EnableWallMessages=no
NAutoVTs=6
KillUserProcesses=no
RebootToFirmwareSetup=no
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
InhibitDelayMaxUSec=5s
UserStopDelayUSec=10s
HandlePowerKey=poweroff
HandleSuspendKey=suspend
HandleHibernateKey=hibernate
HandleLidSwitch=suspend
HandleLidSwitchDocked=ignore
HoldoffTimeoutUSec=30s
IdleAction=ignore
IdleActionUSec=30min
PreparingForShutdown=no
PreparingForSleep=no
Docked=yes
RemoveIPC=yes
RuntimeDirectorySize=400760832
InhibitorsMax=8192
NCurrentInhibitors=0
SessionsMax=8192
NCurrentSessions=2

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da 4javier » 5 gennaio 2019, 13:22

Non riesci a darla da X?
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

magellano
Novello Arciere
Messaggi: 147
Iscritto il: 10 settembre 2016, 9:44

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da magellano » 5 gennaio 2019, 14:02

suggerimenti su come potrei farlo?

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da 4javier » 5 gennaio 2019, 14:06

Non sapendo di preciso quali artefatti grafici si presentino, non saprei dirti. Comunque mi pare tu abbia anche altri utenti oltre ad angelo e ilaria sul sistema: per loro la sessione mate funziona?
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

magellano
Novello Arciere
Messaggi: 147
Iscritto il: 10 settembre 2016, 9:44

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da magellano » 5 gennaio 2019, 14:19

funziona per angelo, non funziona per ilaria, non funziona per altro crearo ad hoc, ma c'è un modo per farlo dall'utente funzionante? perchè le altre due sessioni grafiche sono inutilizzabili
ho trovato nel frattempo questa disussione
https://bbs.archlinux.org/viewtopic.php?id=237162&p=2
un downgrading di xorg-session e xorg-common potrebbe avere un senso?
dove posso trovare eventualmente i vecchi pacchetti (nella cache ho solo i 2 precedenti, ma della serie 1.20, proverei con la 1.19)

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da 4javier » 5 gennaio 2019, 14:49

Se per angelo funziona mate, e per tutti funziona xfce, il problema non dovrebbe essere xorg.
Hai provato ad entrare in tty, loggarti come Ilaria, ed avviare la sessione grafica con startx?
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

magellano
Novello Arciere
Messaggi: 147
Iscritto il: 10 settembre 2016, 9:44

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da magellano » 5 gennaio 2019, 15:11

con startx la gui non parte neanche da utente ok (non ho installato xterm, etc), penso a xorg xhè fino ad apertura del tread funzionava tutto

Per cortesia non ripetere i messaggi inutilmente

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da 4javier » 5 gennaio 2019, 18:03

Ovviamente per lanciare mate da startx devi configurare il tuo .xinitrc
https://wiki.archlinux.org/index.php/MATE#Starting_MATE
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

magellano
Novello Arciere
Messaggi: 147
Iscritto il: 10 settembre 2016, 9:44

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da magellano » 15 aprile 2019, 21:07

ciao a tutti,
riprendo questa discussione dopo un sacco di tempo, ma per varii motivi ho continuato ad utilizzare xfce invece di mate. Adesso il tarlo mi è ripreso.
Riassumo in due righe: su mate gestivo 2 utenti, finchè un bel giorno loggandomi con uno dei due: schermo a righe, mouse non riconosciuto, desktop inutilizzabile.
Con l'altro invece tutto ok. Provo a creare un nuovo utente: idem come sopra. Allora installo anche xfce e per tutti gli utenti tutto ok.
Ora, installo il necessario per avviare la sessione grafica da startx e: con il primo utente, sempre tutto ok, con l'altro invece ho il seguente msg:
could not acquire name on session bus

Avatar utente
TheSaint
Robin Hood
Messaggi: 7712
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da TheSaint » 17 aprile 2019, 9:27

Ma vuoi 2 utenti loggati allo stesso tempo ?
F the saint
12 anni da questo forum ;)

magellano
Novello Arciere
Messaggi: 147
Iscritto il: 10 settembre 2016, 9:44

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da magellano » 17 aprile 2019, 19:19

no, uno dei due utenti ha la gui "rotta": schermo a righe ed icone non identificabili, l'altro non ha problemi

Avatar utente
TheSaint
Robin Hood
Messaggi: 7712
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da TheSaint » 18 aprile 2019, 2:26

A prescindere se funziona, qual è il tuo intento.
Sarebbe utile se si vede qualcosa di rilevante nel journal o in /var/log/Xorg.0.log.old di quello che non funziona, dopo fatta la prova. Forse c'è anche un log di mate.
Infine si cerca in rete con una frase simile a quella dell'errore ;)
F the saint
12 anni da questo forum ;)

magellano
Novello Arciere
Messaggi: 147
Iscritto il: 10 settembre 2016, 9:44

Re: Failed to open protocol names file lib/xorg/protocol.txt

Messaggio da magellano » 6 luglio 2019, 11:24

funziona!
ho pittato casa per cui ho spento tutto per una settimana, ieri sera rimonto e lancio aggornamento: 2 e passa giga di roba
provo ad utilizzare mate anche con l'utente che dava il problema e..............tutto a posto!
Ora: immagino sia impossibile capire quale fosse il problema (in rete non ho trovato nulla circa aggiornamenti che hanno risolto eventuali bug di mate)

Rispondi