Nemo-MEGASync e Doomsday.

Segnalazioni di pacchetti utili, richieste di creazione pacchetti e supporto tecnico
Rispondi
Pival81
Newbie
Messaggi: 20
Iscritto il: 13 novembre 2015, 15:20
Architettura: x86_64 (64bit)

Nemo-MEGASync e Doomsday.

Messaggio da Pival81 » 7 luglio 2016, 9:37

Salve, allora ho due cose da dire:
1) C'è un certo pacchetto sull'AUR, "nemo-megasync", che era stato originariamente provveduto sottoforma di pacchetto deb da Andrew di webupd8.org, che aggiunge a megasync il supporto a nemo (il gestore di file). Siccome Andrew non ha più mantenuto il progetto, decisi di continuarlo io, e si può trovare qui: https://github.com/Pival81/nemo-megasync.
Come si legge nella descrizione del progetto non ho fatto che prendere la tarball di nautilus-megasync (https://mega.nz/linux) e sostituire in tutti i file della tarball la parola "nautilus" con "nemo" e ha funzionato alla grande.
Sarà da una settimana che ho reinstallato arch, e nonostante abbia commentato nella pagina del pacchetto e anche mandato un e-mail al mantenitore, non ho ricevuto nessuna risposta. Sembra anche che ci sia un'altro utente interessato a quello che voglio fare.
C'è qualche "moderatore" che mi può fare manutentore del pacchetto?
2) Ho provato a creare un PKGBUILD per l'ultima versione di doomsday, l'engine di doom, in quanto il pacchetto sull'AUR non sembra venga più aggiornato, e l'ho caricato sull'OpenSuSE Build System, in quanto il mio portatile non ce l'avrebbe fatta (persino obs c'ha messo un ora).
Una volta finito ho provato ad installarlo ma mi dava i seguenti errori:

Codice: Seleziona tutto

caricamento dei pacchetti in corso...
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...

Pacchetti (1) doomsday-2.0.0-2013

Dimensione totale dei pacchetti da installare:  53,33 MiB

:: Vuoi procedere con l'installazione? [S/n] 
(1/1) verifica delle chiavi presenti nel porta...  [######################] 100%
(1/1) verifica dell'integrità dei pacchetti        [######################] 100%
(1/1) caricamento dei file dei pacchetti           [######################] 100%
(1/1) controllo dei conflitti in corso             [######################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
doomsday: /usr/include/assimp/Compiler/poppack1.h è già presente nel filesystem
doomsday: /usr/include/assimp/Compiler/pstdint.h è già presente nel filesystem
doomsday: /usr/include/assimp/Compiler/pushpack1.h è già presente nel filesystem
doomsday: /usr/include/assimp/DefaultLogger.hpp è già presente nel filesystem
doomsday: /usr/include/assimp/Exporter.hpp è già presente nel filesystem
doomsday: /usr/include/assimp/IOStream.hpp è già presente nel filesystem
doomsday: /usr/include/assimp/IOSystem.hpp è già presente nel filesystem
doomsday: /usr/include/assimp/Importer.hpp è già presente nel filesystem
doomsday: /usr/include/assimp/LogStream.hpp è già presente nel filesystem
doomsday: /usr/include/assimp/Logger.hpp è già presente nel filesystem
doomsday: /usr/include/assimp/NullLogger.hpp è già presente nel filesystem
doomsday: /usr/include/assimp/ProgressHandler.hpp è già presente nel filesystem
doomsday: /usr/include/assimp/ai_assert.h è già presente nel filesystem
doomsday: /usr/include/assimp/anim.h è già presente nel filesystem
doomsday: /usr/include/assimp/camera.h è già presente nel filesystem
doomsday: /usr/include/assimp/cexport.h è già presente nel filesystem
doomsday: /usr/include/assimp/cfileio.h è già presente nel filesystem
doomsday: /usr/include/assimp/cimport.h è già presente nel filesystem
doomsday: /usr/include/assimp/color4.h è già presente nel filesystem
doomsday: /usr/include/assimp/color4.inl è già presente nel filesystem
doomsday: /usr/include/assimp/config.h è già presente nel filesystem
doomsday: /usr/include/assimp/defs.h è già presente nel filesystem
doomsday: /usr/include/assimp/importerdesc.h è già presente nel filesystem
doomsday: /usr/include/assimp/light.h è già presente nel filesystem
doomsday: /usr/include/assimp/material.h è già presente nel filesystem
doomsday: /usr/include/assimp/material.inl è già presente nel filesystem
doomsday: /usr/include/assimp/matrix3x3.h è già presente nel filesystem
doomsday: /usr/include/assimp/matrix3x3.inl è già presente nel filesystem
doomsday: /usr/include/assimp/matrix4x4.h è già presente nel filesystem
doomsday: /usr/include/assimp/matrix4x4.inl è già presente nel filesystem
doomsday: /usr/include/assimp/mesh.h è già presente nel filesystem
doomsday: /usr/include/assimp/metadata.h è già presente nel filesystem
doomsday: /usr/include/assimp/postprocess.h è già presente nel filesystem
doomsday: /usr/include/assimp/quaternion.h è già presente nel filesystem
doomsday: /usr/include/assimp/quaternion.inl è già presente nel filesystem
doomsday: /usr/include/assimp/scene.h è già presente nel filesystem
doomsday: /usr/include/assimp/texture.h è già presente nel filesystem
doomsday: /usr/include/assimp/types.h è già presente nel filesystem
doomsday: /usr/include/assimp/vector2.h è già presente nel filesystem
doomsday: /usr/include/assimp/vector2.inl è già presente nel filesystem
doomsday: /usr/include/assimp/vector3.h è già presente nel filesystem
doomsday: /usr/include/assimp/vector3.inl è già presente nel filesystem
doomsday: /usr/include/assimp/version.h è già presente nel filesystem
doomsday: /usr/lib64 è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
Ho preso le istruzioni di build dal file rules nel archivio usato per creare il pacchetto deb su launchpad.
Il pkgbuild si trova qui: https://build.opensuse.org/package/view ... D?expand=1
Mentre il pacchetto compilato si trova qui: http://download.opensuse.org/repositori ... pkg.tar.xz
Prima di aggiornare all'ultima build di oggi (2014) voglio rendere il pacchetto installabile e poi lo pubblico sull'AUR col nome doomsday-daily.
Spero che qualcuno mi possa aiutare! Grazie in anticipo!

Pival81
Newbie
Messaggi: 20
Iscritto il: 13 novembre 2015, 15:20
Architettura: x86_64 (64bit)

Re: Nemo-MEGASync e Doomsday.

Messaggio da Pival81 » 10 luglio 2016, 7:54

Nessuno?

Avatar utente
TheSaint
Robin Hood
Messaggi: 7919
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Nemo-MEGASync e Doomsday.

Messaggio da TheSaint » 10 luglio 2016, 10:28

Siamo in pochi ?
Vai sul forum internazionale ;)
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Pival81
Newbie
Messaggi: 20
Iscritto il: 13 novembre 2015, 15:20
Architettura: x86_64 (64bit)

Re: Nemo-MEGASync e Doomsday.

Messaggio da Pival81 » 10 luglio 2016, 11:20

TheSaint ha scritto:Siamo in pochi ?
Vai sul forum internazionale ;)
infatti c'ho già pensato, sta qua: https://bbs.archlinux.org/viewtopic.php ... 4#p1640044
Ho già risolto il primo problema, devo solo aspettare due settimane da quando ho fatto la richiesta, sempe che elken non si faccia vivo/a.
Per doomsday sto ancora aspettando aiuto.

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Nemo-MEGASync e Doomsday.

Messaggio da ange » 31 luglio 2016, 16:02

Se sei un temerario puoi installare il pacchetto con l'aggiunta dell'opzione "--force", altrimenti lancia un

Codice: Seleziona tutto

pacman -Qo
su quei file e controlla a quale pacchetto appartengono.
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Pival81
Newbie
Messaggi: 20
Iscritto il: 13 novembre 2015, 15:20
Architettura: x86_64 (64bit)

Re: Nemo-MEGASync e Doomsday.

Messaggio da Pival81 » 31 luglio 2016, 16:08

con doomsday ho risolto, ma solo in parte, perchè in pratica quegli errori me li dava perchè conteneva tutti i file del pacchetto assimp, mentre l'ultimo errore riguardava il fatto che ha installato le librerie in /lib64 invece che /usr/lib, perchè da un aggiornamento di pacman che non mi ricordo non accetta più di installare nelle directory che sono solo dei link simbolici.
solo che non ho ancora risolto:
[1] 21079 segmentation fault (core dumped) doomsday
e ora non ci capisco più nulla...

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Nemo-MEGASync e Doomsday.

Messaggio da ange » 31 luglio 2016, 16:12

Codice: Seleziona tutto

[1] 21079 segmentation fault (core dumped) doomsday 
Da quel che ne so, un'errata pacchettizzazione non fa andare un software in segmentation fault, perciò non credo che tu possa fare niente.
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Pival81
Newbie
Messaggi: 20
Iscritto il: 13 novembre 2015, 15:20
Architettura: x86_64 (64bit)

Re: Nemo-MEGASync e Doomsday.

Messaggio da Pival81 » 31 luglio 2016, 16:16

Forse dovevo mettere l'opzione !strip per evitare che tolga roba che non deve togliere?

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Nemo-MEGASync e Doomsday.

Messaggio da ange » 31 luglio 2016, 16:24

Pival81 ha scritto:Forse dovevo mettere l'opzione !strip per evitare che tolga roba che non deve togliere?
Non credo che lo strip abbia tolto qualcosa di fondamentale per il software (anche perché per generare un segmentation fault dovresti fare chiamate ricorsive infinite o accedere a indirizzi di memoria non validi), ma puoi sempre provare.
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Rispondi