Problema installazione Yaourt

Segnalazioni di pacchetti utili, richieste di creazione pacchetti e supporto tecnico
Rispondi
pika99
Novello Arciere
Messaggi: 86
Iscritto il: 20 giugno 2012, 11:57
Architettura: x86_64 (64bit)

Problema installazione Yaourt

Messaggio da pika99 » 10 aprile 2013, 16:33

Ciao a tutti, ho installato ArchLinux + Gnome3 sul mio tablet pc convertibile, un Panasonic Toughbook CF-19 di qualche anno fa.
Il touchscreen però non è calibrato e leggendo su internet ho scoperto che devo installare un pacchetto da AUR, quindi devo installare Yaourt, però al momento dell'installazione mi dice:

Codice: Seleziona tutto

errore: package-query: missing required signature
:: Il file /var/cache/pacman/pkg/package-query-1.2-2-x86_64.pkg.tar.xz è corrotto (il pacchetto non è valido oppure è corrotto (firma PGP)).
Vuoi eliminarlo? [S/n] 
Però sia se metto si o no mi dice che non ha installato nulla. Come faccio a risolvere?

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Re: Problema installazione Yaourt

Messaggio da Hilinus » 10 aprile 2013, 18:32

Installa manualmente il pacchetto con pacman -U, oppure se hai abilitato il repo archlinuxfr disattiva il controllo delle firme dei pacchetti visto che stando al wiki, questo repo non fornisce una chiave pubblica per la verifica.
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

pika99
Novello Arciere
Messaggi: 86
Iscritto il: 20 giugno 2012, 11:57
Architettura: x86_64 (64bit)

Re: Problema installazione Yaourt

Messaggio da pika99 » 10 aprile 2013, 19:15

Hilinus ha scritto:Oppure se hai abilitato il repo archlinuxfr disattiva il controllo delle firme dei pacchetti visto che stando al wiki, questo repo non fornisce una chiave pubblica per la verifica.
Grazie, sono riuscito a risolvere :)

darkanmoore
Novello Arciere
Messaggi: 94
Iscritto il: 11 aprile 2013, 20:01

Re: Problema installazione Yaourt

Messaggio da darkanmoore » 16 aprile 2013, 0:23

Scusate, potreste spiegarmi meglio il passaggio per risolvere questo problema, in quanto anche io lo sto riscontrando e anche se sono riuscito ad installare yaourt l'installazione dei pacchetti mi da comunque dei problemi. Di preciso mi dice ogni volta che uso yaourt che devo modificare il file di PGK.

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: Problema installazione Yaourt

Messaggio da KleinerMann » 16 aprile 2013, 8:59

Quello è normale. Rispondi no alle domande di modificare i file da parte di yaourt :)
Arch Linux - AwesomeWM

Rispondi