[Risolto] Aiuto con Webkam?

Segnalazioni di pacchetti utili, richieste di creazione pacchetti e supporto tecnico
Rispondi
Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

[Risolto] Aiuto con Webkam?

Messaggio da ange » 12 agosto 2012, 18:44

Salve a tutti, volevo installare un pacchetto che mi facesse usare la webcam, fare foto, configurarla, ecc... Io come programma che fa queste cose, conosco Cheese, ma è per GNOME, e mi porterebbe dietro parecchie dipendenze, poi i pacchetti gtk-qt-engine e gtk-kde4, migliorano la grafica delle applicazioni in GTK e GTK 2, ma non della v.3, perciò mi ritroverei con uno schifo che mi fa le foto (almeno quello...)... Perciò in rete mi sono imbattuto in un programma, chiamato "Webkam"... Ho digitato yaourt webkam, per verificarne l'esistenza (altrimenti faccio qualche ricerca, tipo webkam archlinux) e noto che è su AUR, allora premo 1, faccio n per il PKGBUILD e s per continuare la compilazione... Ma all'improvviso mi dice che non è riuscito a trovare le dipendenze richieste... La dipendenza mancante è qt4-qtruby ... Qualcuno di voi ne sa qualcosa?
2. cosa: possiedo una webcam integrata nel notebook nella firma... Noto che quando cerco di fare una video-chiamata (uso skype e programmi simili...), sono al contrario... È possibile che manchi qualcosa? Visto che ho fatto qualche ricerca, ma noto che uno mi dice che manca il pacchetto "linux-uvc" (è una patch del kernel o un kernel patchato?), mentre un altro non capisco che pacchetto voglia...
Recent versions of the device use UVC as a façade. They talk a vendor-specific protocol with a vendor-provided Windows driver, and trying to handle them with the UVC protocol results in low frame rate and corrupted frames in most resolutions. Device BCD 1.00 is known to be affected, BCD 0.02 seems to work.
PS: ho seguito questo piccolo post e noto che uvcvideo è già nel kernel... Ma senza Webkam, ora non so se il problema è risolto o meno...
Ultima modifica di ange il 19 gennaio 2013, 17:21, modificato 3 volte in totale.
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Re: Aiuto con Webkam?

Messaggio da veleno77 » 12 agosto 2012, 20:23

prova kamerka o kamoso
per il video al contrario.. è una cosa che ho già sentito tempo fa.. ma non ricordo bene dove
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da ange » 12 agosto 2012, 20:47

... Ho provato a scaricarli (sono in AUR, no?), ma mi da sempre errore... Non capisco come fare per proseguire...

Codice: Seleziona tutto

==> Continuare la compilazione di kamerka [S/n]
==> -------------------------------------------
==> 
==> Compilazione e installazione del pacchetto
==> Creazione del pacchetto: kamerka 0.8.1-1 (dom 12 ago 2012, 20.45.03, CEST)
==> Controllo delle dipendenze durante l'avvio in corso...
==> Controllo delle dipendenze durante la compilazione in corso...
==> Download dei sorgenti in corso...
  -> Download di kamerka-0.8.1.tar.gz in corso...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:03 --:--:--     0curl: (7) couldn't connect to host
==> ERRORE: Impossibile scaricare kamerka-0.8.1.tar.gz
    L'operazione sta per essere interrotta...
==> ERRORE: Makepkg non è riuscito a compilare kamerka.
==> Riavviare la compilazione di kamerka [s/N]
==> ------------------------------------------
==> 
mentre per Kamoso

Codice: Seleziona tutto

==> Continuare la compilazione di kamoso [S/n]
==> ------------------------------------------
==> 
==> Compilazione e installazione del pacchetto
==> Creazione del pacchetto: kamoso 2.0.2-4 (dom 12 ago 2012, 20.47.08, CEST)
==> Controllo delle dipendenze durante l'avvio in corso...
==> Controllo delle dipendenze durante la compilazione in corso...
==> Download dei sorgenti in corso...
  -> Download di kamoso-2.0.2.tar.bz2 in corso...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  132k  100  132k    0     0   121k      0  0:00:01  0:00:01 --:--:--  127k
==> Validazione dei sorgenti con md5sums in corso...
    kamoso-2.0.2.tar.bz2 ... Verificato
==> Estrazione dei sorgenti in corso...
  -> Estrazione di kamoso-2.0.2.tar.bz2 con bsdtar in corso...
==> Avvio di build() in corso...
-- The C compiler identification is GNU 4.7.1
-- The CXX compiler identification is GNU 4.7.1
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.8.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found.
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Found OpenSSL: /usr/lib/libssl.so
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4 
-- Found Perl: /usr/bin/perl (found version "5.16.1") 
-- Found Phonon: /usr/include 
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.8 include dir: /usr/include
-- Found KDE 4.8 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Check Kipi library in local sub-folder...
-- Check Kipi library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig
-- Found libkipi release >= 0.2.0
-- Found libkipi: /usr/lib/libkipi.so
-- Found Phonon: /usr/include 
-- checking for module 'glib-2.0'
--   found glib-2.0, version 2.32.4
-- Found GLIB2: /usr/lib/libglib-2.0.so 
-- checking for module 'gstreamer-0.10'
--   found gstreamer-0.10, version 0.10.36
-- Found GStreamer: /usr/lib/libgstreamer-0.10.so 
-- Found QtGStreamer: /usr/include/QtGStreamer 
-- Boost hasn't been found yet. Looking...
CMake Error at /usr/share/cmake-2.8/Modules/FindBoost.cmake:1191 (message):
  Unable to find the requested Boost libraries.

  Unable to find the Boost header files.  Please set BOOST_ROOT to the root
  directory containing Boost or BOOST_INCLUDEDIR to the directory containing
  Boost's headers.
Call Stack (most recent call first):
  /usr/share/apps/cmake/modules/FindBoost.cmake:24 (include)
  /usr/lib/QtGStreamer/QtGStreamerConfig.cmake:88 (find_package)
  CMakeLists.txt:10 (find_package)


-- GCC 4.5 or later detected. Enabling C++0x support in QTGSTREAMER_FLAGS.
-- Found Soprano: /usr/include  (found version "2.8.0", required is "1.99")
-- Found SharedDesktopOntologies: /usr/share/ontology 
-- Found Nepomuk: /usr/lib/libnepomuk.so;/usr/lib/libsoprano.so 

-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
-----------------------------------------------------------------------------
   * Nepomuk - Handles all kinds of metadata on the KDE desktop to provide a semantic desktop

-----------------------------------------------------------------------------
-- Congratulations! All external packages have been found.
-----------------------------------------------------------------------------

-- Found Kipi library in cache: /usr/lib/libkipi.so
-- Looking for dgettext
-- Looking for dgettext - found
-- Found Gettext: built in libc
-- Configuring incomplete, errors occurred!
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
==> ERRORE: Makepkg non è riuscito a compilare kamoso.
==> Riavviare la compilazione di kamoso [s/N]
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da Hilinus » 12 agosto 2012, 21:12

Per Kamoso credo manchi boost all'elenco delle dipendenze, mentre il sorgente del primo pacchetto restituisce un errore in connessione al server. Magari non è più sviluppato o è cambiato l'URL...
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Re: Aiuto con Webkam?

Messaggio da veleno77 » 12 agosto 2012, 21:12

per kamerka risulta inaccessibile il server .. sarà il link errato per i sorgenti, kamoso non compila neanche a me ooopsss anticipato :D

per kamoso c'è la versione git.. ma richiede gstreamer-git che da conflitti con le librerie installate
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da ange » 12 agosto 2012, 21:37

Kamoso è installato, ma credo manchino i driver, visto che Kamoso mi rimane nero e poi va in crash... Usando centro d'informazione di KDE, ottengo i seguenti dettagli:
Prodotto: USB 2.0 Camera
Fornitore: Sonix Technology Co. Ltd.
Driver Supportati: uvcvideo
Protocolli supportati: video4linux
---------------------------------------------------
Ciò che avevo detto nel primo messaggio (nel PS, non ha funzionato...) :(
PS: ho installato Kamoso-git...
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da KleinerMann » 12 agosto 2012, 21:49

ange ha scritto:Noto che quando cerco di fare una video-chiamata (uso skype e programmi simili...), sono al contrario... È possibile che manchi qualcosa?
la wiki ange, la wiki... https://wiki.archlinux.org/index.php/Sk ... CA_webcams
Arch Linux - AwesomeWM

Avatar utente
narco
Arciere
Messaggi: 221
Iscritto il: 6 marzo 2012, 4:01
Località: http://bit.ly/YZwQ4H

Re: Aiuto con Webkam?

Messaggio da narco » 12 agosto 2012, 22:19


Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da ange » 13 agosto 2012, 0:04

Ok ora ho Kamoso e per ora funziona! (non so cos'ho fatto, perciò finchè non riavvierò e non mi assicurerò che funziona nuovamente, non aggiungo il tag risolto... Meglio non cantare vittoria troppo presto... :D )
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da ange » 13 agosto 2012, 0:10

ok ho riavviato e funziona benissimo... Io ho soltanto aggiunto (nuovamente) il mio utente al gruppo video e ho seguito tutto come scritto sulla fantastica wiki...
ArchWiki ha scritto:udev
If you use udev, you only need to be in the group video. You can check it with:
$ groups
To add a user to the group run under root:
# gpasswd -a <username> video
Note the next two steps may not be required as they should already be set by udev
Set group of device to video:
# chgrp video /dev/video0
Set permissions of the device:
# chmod 660 /dev/video0
devfs
Add the following to your /etc/devfsd.conf. This will give normal users permission to use /dev/video0 (your webcam).
# Give normal users access to webcam
REGISTER video0 PERMISSIONS root.users 0660
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Re: Aiuto con Webkam?

Messaggio da veleno77 » 13 agosto 2012, 1:00

ange ha scritto:Kamoso è installato, ma credo manchino i driver, visto che Kamoso mi rimane nero e poi va in crash... Usando centro d'informazione di KDE, ottengo i seguenti dettagli:
Prodotto: USB 2.0 Camera
Fornitore: Sonix Technology Co. Ltd.
Driver Supportati: uvcvideo
Protocolli supportati: video4linux
---------------------------------------------------
Ciò che avevo detto nel primo messaggio (nel PS, non ha funzionato...) :(
PS: ho installato Kamoso-git...
a me non compila kamoso

Codice: Seleziona tutto

[ 46%] Building CXX object src/plugins/youtube/CMakeFiles/kipiplugin_youtube.dir/kipiplugin_youtube.o                                                    
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:47:1: warning: unused parameter ‘args’ [-Wunused-parameter]
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp: In member function ‘virtual KJob* YoutubePlugin::exportFiles(const QString&)’:
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: invalid use of incomplete type ‘class KIPI::ImageCollection’
In file included from /home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:38:0:
/usr/include/libkipi/interface.h:62:7: error: forward declaration of ‘class KIPI::ImageCollection’
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: template argument 1 is invalid
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: invalid type in declaration before ‘(’ token
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: invalid use of incomplete type ‘class KIPI::ImageCollection’
In file included from /home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:38:0:
/usr/include/libkipi/interface.h:62:7: error: forward declaration of ‘class KIPI::ImageCollection’
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘brk’ in ‘_container_’, which is of non-class type ‘int’
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘i’ in ‘_container_’, which is of non-class type ‘int’
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘e’ in ‘_container_’, which is of non-class type ‘int’
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘brk’ in ‘_container_’, which is of non-class type ‘int’
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘i’ in ‘_container_’, which is of non-class type ‘int’
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘i’ in ‘_container_’, which is of non-class type ‘int’
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘brk’ in ‘_container_’, which is of non-class type ‘int’
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp: At global scope:
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:51:7: warning: unused parameter ‘albumname’ [-Wunused-parameter]
/home/bash/projects/archlinux/packages/kamoso/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:62:16: warning: unused parameter ‘action’ [-Wunused-parameter]
make[2]: *** [src/plugins/youtube/CMakeFiles/kipiplugin_youtube.dir/kipiplugin_youtube.o] Error 1
make[1]: *** [src/plugins/youtube/CMakeFiles/kipiplugin_youtube.dir/all] Error 2
make: *** [all] Error 2
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
ilpianista
Amministratore
Messaggi: 2952
Iscritto il: 6 ottobre 2007, 0:41
Località: Lecce, Italy
Contatta:

Re: Aiuto con Webkam?

Messaggio da ilpianista » 13 agosto 2012, 10:41

veleno77 ha scritto:a me non compila kamoso

Codice: Seleziona tutto

[ 46%] Building CXX object src/plugins/youtube/CMakeFiles/kipiplugin_youtube.dir/kipiplugin_youtube.o                                                    
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:47:1: warning: unused parameter ‘args’ [-Wunused-parameter]
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp: In member function ‘virtual KJob* YoutubePlugin::exportFiles(const QString&)’:
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: invalid use of incomplete type ‘class KIPI::ImageCollection’
In file included from /build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:38:0:
/usr/include/libkipi/interface.h:62:7: error: forward declaration of ‘class KIPI::ImageCollection’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: template argument 1 is invalid
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: invalid type in declaration before ‘(’ token
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: invalid use of incomplete type ‘class KIPI::ImageCollection’
In file included from /build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:38:0:
/usr/include/libkipi/interface.h:62:7: error: forward declaration of ‘class KIPI::ImageCollection’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘brk’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘i’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘e’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘brk’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘i’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘i’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘brk’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp: At global scope:
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:51:7: warning: unused parameter ‘albumname’ [-Wunused-parameter]
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:62:16: warning: unused parameter ‘action’ [-Wunused-parameter]
make[2]: *** [src/plugins/youtube/CMakeFiles/kipiplugin_youtube.dir/kipiplugin_youtube.o] Error 1
make[1]: *** [src/plugins/youtube/CMakeFiles/kipiplugin_youtube.dir/all] Error 2
make: *** [all] Error 2
aggiungi

Codice: Seleziona tutto

#include <libkipi/imagecollection.h>
alla lista degli header presenti in kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp

PS. veleno ho modificato il tuo messaggio d'errore con uno piu` significativo ;)

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: [Risolto] Aiuto con Webkam?

Messaggio da ange » 13 agosto 2012, 14:11

@veleno: se come ha detto bash non funziona, usa la versione git... Io ce l'ho e non mi ha creato nessun problema e funziona tutto perfettamente :D
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Avatar utente
ilpianista
Amministratore
Messaggi: 2952
Iscritto il: 6 ottobre 2007, 0:41
Località: Lecce, Italy
Contatta:

Re: [Risolto] Aiuto con Webkam?

Messaggio da ilpianista » 13 agosto 2012, 16:03

ange ha scritto:@veleno: se come ha detto bash non funziona, usa la versione git
...credo tu abbia sbagliato qualcosa ;)

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: [Risolto] Aiuto con Webkam?

Messaggio da ange » 13 agosto 2012, 19:53

come non detto... Problema irrisolto... Non so come mai, ma è tornato non-funzionante... Per caso usando un altro kernel (uso il pf), cambierebbe qualcosa? Ho il kernel core e quello lts già installati e pronti all'uso... IMHO manca qualcosa, ma non saprei cosa... È come se Kamoso non facesse avviare la webcam... O magari manca il driver apposito, visto che con wxcam è al contrario (proprio letteralmente, sono a testa in giù anche se giro il pc...)... Ora provo a ricontrollare la wiki, sperando di trovare qualcosa...
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da KleinerMann » 13 agosto 2012, 20:01

ange ha scritto:visto che con wxcam è al contrario (proprio letteralmente, sono a testa in giù anche se giro il pc...
hai letto il link che ti ho postato? riguarda skype certo ma dovrebbe funzionare con ogni applicazione che richiede la webcam... conosco gente usa quella "soluzione" per i video ritrovi di google plus, quindi lancia firefox in quel modo... :D
Arch Linux - AwesomeWM

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Re: Aiuto con Webkam?

Messaggio da veleno77 » 13 agosto 2012, 20:32

bash ha scritto:
veleno77 ha scritto:a me non compila kamoso

Codice: Seleziona tutto

[ 46%] Building CXX object src/plugins/youtube/CMakeFiles/kipiplugin_youtube.dir/kipiplugin_youtube.o                                                    
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:47:1: warning: unused parameter ‘args’ [-Wunused-parameter]
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp: In member function ‘virtual KJob* YoutubePlugin::exportFiles(const QString&)’:
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: invalid use of incomplete type ‘class KIPI::ImageCollection’
In file included from /build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:38:0:
/usr/include/libkipi/interface.h:62:7: error: forward declaration of ‘class KIPI::ImageCollection’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: template argument 1 is invalid
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: invalid type in declaration before ‘(’ token
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: invalid use of incomplete type ‘class KIPI::ImageCollection’
In file included from /build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:38:0:
/usr/include/libkipi/interface.h:62:7: error: forward declaration of ‘class KIPI::ImageCollection’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘brk’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘i’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘e’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘brk’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘i’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘i’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:55:5: error: request for member ‘brk’ in ‘_container_’, which is of non-class type ‘int’
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp: At global scope:
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:51:7: warning: unused parameter ‘albumname’ [-Wunused-parameter]
/build/src/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp:62:16: warning: unused parameter ‘action’ [-Wunused-parameter]
make[2]: *** [src/plugins/youtube/CMakeFiles/kipiplugin_youtube.dir/kipiplugin_youtube.o] Error 1
make[1]: *** [src/plugins/youtube/CMakeFiles/kipiplugin_youtube.dir/all] Error 2
make: *** [all] Error 2
aggiungi

Codice: Seleziona tutto

#include <libkipi/imagecollection.h>
alla lista degli header presenti in kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.cpp

PS. veleno ho modificato il tuo messaggio d'errore con uno piu` significativo ;)
@bash sei un genio....!!!! compilato.... !!!!!

@ange come detto non voglio usare la versione git perchè devo compilare gstreamer-git che fa numerosi conflitti da insallare con --force e la cosa non mi garba per niente...
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da ange » 14 agosto 2012, 2:09

Ho installato kamoso... Ma non mi è servito fare tutto ciò che avete scritto... Il manutentore del pacchetto l'ha aggiustato? Per installarlo ho dato un semplice "yaourt -G kamoso", ho aperto la cartella, "makepkg -s" e "sudo pacman -U <pacchetto>"... Però il problema rimane... La webcam, quando il programma si avvia, sembra non ricevere il comando di avviarsi, quando uso webkam o kamoso (uso la git, come ho già detto...)... Con gli altri programmi, invece, il video è capovolto (es. wxcam)...
Forse mancano i privilegi per avviare la webcam, ma non saprei come fare... (con la wiki non ho risolto...)
UPDATE: Ora tutti i software di gestione webcam funzionano normalmente :D Non so come mai ma meglio così
Ultima modifica di ange il 19 gennaio 2013, 17:21, modificato 1 volta in totale.
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da ange » 5 dicembre 2012, 19:24

sto coglio*e mi sta rompendo il ca**o! :@ richiedo la cancellazione immediata dell'account
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da Hilinus » 5 dicembre 2012, 19:41

ange ha scritto:sto coglio*e mi sta rompendo il ca**o! :@ richiedo la cancellazione immediata dell'account
Mica è un cogli**ne... è un bot, non ha emozioni :P

Comunque l'ho bannato e ho cancellato i post.
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Avatar utente
ange
Robin Hood
Messaggi: 1866
Iscritto il: 20 giugno 2012, 23:02
Architettura: x86_64 (64bit)

Re: Aiuto con Webkam?

Messaggio da ange » 5 dicembre 2012, 20:31

hahhahaha XD è vero!!!
Notebook ASUS A52J | Kubuntu 16.04 LTS amd64 | KDE Plasma Desktop
Notebook HP Pavilion G6-1352el | Arch Linux x86_64

Rispondi