Pagina 5 di 23

Inviato: 7 febbraio 2010, 17:39
da dieghen89
Si già stavo facendo piano piano un abbozzo sul primo post...ora ho dato una sistemata...

I modelli li ho scritti anche guardando vari lspci su altri forum/siti...se avete altri modelli da proporre li aggiungo volentieri...

Inviato: 8 febbraio 2010, 17:12
da marinz
ciao, ho installato la rev7: la batteria in yacpi è ritornata, il boot è perfetto, funziona tutto :cool:

ottimo lavoro :cool:

Inviato: 8 febbraio 2010, 17:16
da dieghen89
Ok perfetto...per fortuna mi ricordavo di quelle opzioni per acpi che avevo tolto :P

Inviato: 8 febbraio 2010, 22:16
da fortAlamo
ho provato ad installare il kernel (v7) sul mio acer aspire one.

al boot ho un doppio "fatal module not found", per acpi_cpufreq e per memstick
momentaneamente li ho rimossi da rc.conf, in attesa di capire se siano effettivamente necessari.


il "vero" problema - e non so come risolvere :rolleyes: - e' che con la /home criptata,
l'avvio si interrompe causa il fatale fallimento del controllo filesystem ( non trova il dm_mod kernel module )

Inviato: 8 febbraio 2010, 22:21
da dieghen89
Si quell'errore è appunto perchè ce li hai in rc.conf e non serve con questo kernel....

Per la /home criptata....beh non mi sono mai interessato :/ sicuramente manca qualche modulo....indagherò...

Inviato: 8 febbraio 2010, 22:32
da fortAlamo
grazie, mi piacerebbe proprio usare 'sto ...kernelino :)



info (inutile):
anch'io ho il "problema" del .install, pur eseguendo pacman -U direttamente da root

Inviato: 9 febbraio 2010, 18:40
da dieghen89
@fortAlamo
mi puoi postare il lsmod dal kernel generico? non riesco a capire che moduli attivare per il supporto alle partizioni criptate...

Inviato: 9 febbraio 2010, 18:56
da Asa
fortAlamo ha scritto:l'avvio si interrompe causa il fatale fallimento del controllo filesystem ( non trova il dm_mod kernel module )
il modulo dm_mod è quello che gestisce anche LVM, se se ne vuole includere il supporto io lo posso testare.

Inviato: 9 febbraio 2010, 19:05
da dieghen89
@tutti
la 2.6.32.8-1 l'ho uploadata qua.
Rispetto all'ultima release .7-7 non ho toccato il config...

@quelli a cui manca qualcosa
ora vorrei sistemare piano piano un po' tutti i problemi...quindi:
@Asa
ora provo a ricompilare aggiungendo LVM...tra poco ti do qua il link per scaricare il pacchetto così puoi testarlo...
@fortAlamo
come #107
@neubauten
sono ancora in cerca di illuminazione :P

Cmq è una goduria poter compilare sul fisso, in 5 minuti ho il kernel già pronto :D:lol:

Inviato: 9 febbraio 2010, 19:29
da dieghen89
@Asa
prova questo...

Inviato: 9 febbraio 2010, 20:12
da Asa
dieghen89 ha scritto:@Asa
prova questo...
Sembra che sia corrotto il pacchetto, sia scaricandolo dal browser che con wget risulta incomprensibile per pacman (ed anche per tar), ho provato con il tar.gz della versione precedente e non ha questo problema, quindi credo sia un problema upstream, magari si è corrotto in upload.

Se avessi un po' di tempo in più provvederei a ricompilarmelo da me ma sono pesantemente sotto esami e sto studiando :(

Inviato: 9 febbraio 2010, 20:16
da dieghen89
Si sicuramente è un problema di upload...Ora te lo riuppo...

Inviato: 9 febbraio 2010, 20:35
da dieghen89
Eccolo...

@fortAlamo
ho aggiunto i moduli per le partizioni criptate...MA, se non ho capito male dalla documentazione online ha bisogno di immagine di initrd e questo kernel ne è sprovvisto...Quindi prova a bootare questo kernel, se non funziona non ci sono speranze...O rimani col generic o te lo ricompili tu aggiungendo l'immagine di initrd...

Inviato: 9 febbraio 2010, 21:05
da Asa
Niente da fare kernel panic perchè impossibile montare il root file system...

Inviato: 9 febbraio 2010, 21:08
da dieghen89
Manca ancora qualcos'altro allora :/

Ora c'è dr house forse dopo gli dò un'altra occhiata...sennò domani...

Inviato: 9 febbraio 2010, 21:12
da Asa
Grazie mille del tuo impegno, magari faccio anch'io una ricerca su cosa può servire.
Sono sicuro che dm_mod è l'unico modulo che va caricato a mano per usare LVM, non mi pare ne servano altri.

EDIT: sembra che come per le partizioni criptate anche per LVM sia necessario un initrd qui spiega perchè.

presto provo con un initrd, mal che vada sarebbe un initrd dimagrito

Inviato: 9 febbraio 2010, 21:38
da marinz
si da quel link sembra che ti serva un'immagine di init (solo se hai criptato la root)

Inviato: 9 febbraio 2010, 21:46
da Asa
el_cammello ha scritto:si da quel link sembra che ti serva un'immagine di init (solo se hai criptato la root)
esatto se è criptata o semplicemente su LVM. Bisogna prima attivare i virtual filesystem e per montarli e servono eseguibili contenuti in /sbin per poterlo fare, un cane che si morde la coda.

Inviato: 9 febbraio 2010, 21:58
da dieghen89
Allora il dubbio si chiude qua...Mi era già venuto per i fs criptati leggendo il wiki di gentoo ma non credevo servisse l'initrd anche per LVM....:/

Inviato: 9 febbraio 2010, 23:14
da #!/bin/bash
stò provando questo kernel sul mio aspire one con quick-init, è normale che all'avvio dica che non riesce a caricare determinati moduli (che ora non mi vengono in mente)?
inoltre, avete problemi con i driver video intel?

Inviato: 9 febbraio 2010, 23:21
da dieghen89
Che moduli di preciso? Se leggi bene la discussione, anche qualche post fa, se carichi in rc.conf roba tipo cpufreq o altro, i moduli sono interni al kernel ed è normale che non li trova....Devi toglierli da li...L'importante è che funzioni tutto...

Driver intel, problemi in che senso??

Inviato: 9 febbraio 2010, 23:26
da #!/bin/bash
controllerò, grazie della dritta :)
problemi tipo che dopo qualche ora che ho l'aspire acceso, lo schermo si fa nero e devo per forza spegnere manualmente.
succede anche su ubuntu karmic, secondo me sono proprio i driver video intel che non sono buoni...

Inviato: 9 febbraio 2010, 23:28
da dieghen89
Sul mio eeepc non mi è mai successo...dovresti chiedere a el_cammello che ha un aspire come te...

Inviato: 10 febbraio 2010, 13:42
da fortAlamo
dieghen89 ha scritto:ho aggiunto i moduli per le partizioni criptate..
ottimo, funziona!
grazie. :)

mi pare che le uniche cose non funzionanti siano i lettori di SD (memstick)

#!/bin/bash ha scritto:stò provando questo kernel sul mio aspire one ....
inoltre, avete problemi con i driver video intel?
sul mio aspirino ho lasciato SOLO fuse in modules e no, non ho problemi col driver video.

Inviato: 10 febbraio 2010, 16:27
da dieghen89
@fortAlamo
oh bene....almeno con te ho risolto! ;)

Per il lettore di sd mi servirebbe il modulo da includere...evidentemente è diverso dal mio sull'eeepc....